can mozilla provide one option to allow user to toggle proxy between "direct", "manual", "pac" or even "gnome system config"?

RESOLVED WONTFIX

Status

()

Core
Networking
RESOLVED WONTFIX
14 years ago
2 years ago

People

(Reporter: Jerry, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

currently, there are 4 types of proxy choices.
there are "direct", "manual", "pac", "gnome system config"(only used by gtk2 users).
user will select one from them.
if the selected proxy option is failed, stop.

Can mozilla provide one preference option, 
if it is enable, 
mozilla will toggle proxy settings between those 4 options.
of course these 4 options have their priorities.
"direct" has the highest priority, 
"manual" , then "pac", then "gnome system config".

that is to say, 
if use select "direct" is failed,  mozilla will try to connect with "manual"
settings, if failed, it will continue to try with "pac", 
if failed, it will try with "gnome system config".


If user select "manual" is failed, mozilla will try to connect with "direct", if
failed, it will go on with "pac", then "gnome system config".

this perfercens option can help mozilla to be more smart.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Not a bug in the preferences dialog (please read the component description). 
The consumers of the prefs are responsible for their own pref panels.
Assignee: prefs → darin
Component: Preferences → Networking
QA Contact: benc

Comment 2

14 years ago
bz: hmm.. i think UI people should be involved in the design of pref panels. 
the backend work for this is necko centric.. but as for the pref panel design..
that really requires feedback from UI folks.
(Reporter)

Comment 3

14 years ago
pac has provide proxy failover function, 
this bug could be marked as proxy failover between all 3 options
(for gtk2 user, 4 options)

Updated

12 years ago
Assignee: darin → nobody
QA Contact: benc → networking
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.