When pressing F5 for refresh in print preview the browser goes back to normal mode without buttons/tabs

RESOLVED DUPLICATE of bug 126719

Status

()

Core
Print Preview
RESOLVED DUPLICATE of bug 126719
15 years ago
15 years ago

People

(Reporter: Max Gordon, Unassigned)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

When viewing a page in print preview and then pressing F5 for refresh the page
refreshes but at the same time jumps back to normal mode, ie the page layout
disappears. As it jumps back the old preview buttons are left (The Print; Page
Setup; |<; <; >; >|...) and it is impossible to get back to ordingary view mode
without closing the browser and reopening it. 

Reproducible: Always

Steps to Reproduce:
1. Go to file menu on any page.
2. Choose print preview.
3. When in print preview press F5 for refreshing the page.

Actual Results:  
The browser bugs out and leaves you in a normal view mode but with the preview
buttons and it is not possible to go back.

Expected Results:  
I think correct behaviour should be that the browser reloads the page and then
renders it again in print preview. 

I encountered this bug when trying to work with very advanced CSS pages and it
is a lot of work closing down the preview each time I move an object a few
inches left/right and therefore I think that the best method is to let the
browser fetch the updated page and thereafter remaking the preview instead of
exiting the preview function.

I would be very glad if this could be fixed. I don't think it's a big thing. The
browser just has to remember to check if it's in preview mode before refreshing.

I found a similar bug that was about the preview crashing when updating but this
is not what I would call a crash and therefore I chose to file a new bug.

*** This bug has been marked as a duplicate of 126719 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.