If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Only the first page prints of a multiple page item

RESOLVED DUPLICATE of bug 245887

Status

()

Core
Printing: Output
--
major
RESOLVED DUPLICATE of bug 245887
14 years ago
13 years ago

People

(Reporter: Rob, Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007

Only the first page of a news story will print. The page counter will show "1 of
2", but "2 of 2" is usually blank (or just shows footer info).

Reproducible: Always

Steps to Reproduce:
1. go to http://www.chroniclejournal.com
2. select any mutli-page news item
3. print the news story, only the 1st page will have text. The remaining pages
will show just the footer information.



Expected Results:  
The entire text should of have printed.

This problem exists in early version of Mozilla and across platforms (ex. OS/2).

Comment 1

14 years ago
Reproduced this with FB Gecko/20031027. You actually can reproduce this using
Print Preview (no need to actually print).

I had to change the URL on the bug, because the original one was too short to
trigger a page break - the current one has two paragraphs that should be
rendered on the second page.

I'll be looking for a dupe in a second.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All

Comment 2

14 years ago
Bug 127527 is related but not the same. 

The content in this page is in a table, and it doesn't contain a single line
break --- it's a LONG line. I don't have a minute free to hack a testecase, but
it's a good hypothesis for a testcase hacker.

Comment 3

14 years ago
http://www.accd.edu/sac/nursing/math/ivprob.html seems to show the
same problem on Mozilla app suite build 2003110115, Windows 2000 OS,
Canon S520 inkjet printer.

Comment 4

14 years ago
(fix summary spelling)
Summary: Only the first page prints of a mutli-page item. → Only the first page prints of a multiple page item

Comment 5

14 years ago
My own web page showed the same problem with Mozilla 1.7 beta and Firefox
2004-04-04 build.

This doesn't print more than the first page:

  #content {
    position: absolute;
    float: none;
  }

This works:

  #content {
    float: none;
  }

Comment 6

14 years ago
(In reply to comment #5)
> My own web page showed the same problem with Mozilla 1.7 beta and Firefox
> 2004-04-04 build.
> 
> This doesn't print more than the first page:
> 
>   #content {
>     position: absolute;
>     float: none;
>   }
>

If someone wants to play with this - my url I discovered this on is
http://www.rebee.clara.net/news.html, and the style sheet in question is
http://www.rebee.clara.net/print.css

 
> This works:
> 
>   #content {
>     float: none;
>   }
> 

(In reply to comment #5)
>   #content {
>     position: absolute;
>     float: none;
>   }

That's bug 154892, but doesn't seem related to the original bug in this bug report.

Comment 8

14 years ago
(In reply to comment #7)
> (In reply to comment #5)
> >   #content {
> >     position: absolute;
> >     float: none;
> >   }
> 
> That's bug 154892, but doesn't seem related to the original bug in this bug
report.

(In reply to comment #7)
> (In reply to comment #5)
> >   #content {
> >     position: absolute;
> >     float: none;
> >   }
> 
> That's bug 154892, but doesn't seem related to the original bug in this bug
report.

Oops, mea culpa.  I had too many tabs open.  But I hadn't found Bug 154892.  Thanks.

Updated

13 years ago

Comment 9

13 years ago
Created attachment 158448 [details]
testcase1

The reason the second page would not display in print preview was that it got
moved to the right off the side of the screen.	This testcase shows the
problematic behavior.

Comment 10

13 years ago
I am marking this bug a duplicate of bug 245887, which deals with the problem
I've described.  Feel free to reopen this bug if you disagree with this assessment.

*** This bug has been marked as a duplicate of 245887 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: testcase
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.