'select the quote' preference causes signature to be selected as well

RESOLVED DUPLICATE of bug 74779

Status

MailNews Core
Composition
--
minor
RESOLVED DUPLICATE of bug 74779
14 years ago
10 years ago

People

(Reporter: Andy Potter, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

When forwarding a message where the original message text is included inline 
and is automatically selected. The signature I have set is included but also 
selected. So that when I go to replace the selected body text by simply 
starting to type, the signature is removed as well.

Reproducible: Always

Steps to Reproduce:
1. Under Mail and Newsgroups Account settings, I have setup the composition 
options for my account so that "compose messages in HTML format" is NOT ticked. 
And, "Automatically quote the original message when replying" is ticked. The 
combo box labelled "Then," is set to "select the quoted text".

2. Under Mail and Newsgroups Account settings, I have selected a signature file 
for my account and the "Attach this signature" option is ticked.

2. Under "Preferences->Main and Newsgroups->Composition" the "Forward messages" 
combo box is set to "Inline".

3. When I forward a message, the Compose window appears and the original 
message appears in the body section of the new message. The signature also 
appears after the original text as a would expect.
Actual Results:  
The PROBLEM is that all the body text is selected. This means as soon as I type 
into the body text window to replace the included text, the signature is 
removed as well because it is also selected.

Expected Results:  
I would expect only the included text from the original message to be selected, 
NOT the signature. This would mean if I want to replace the original message 
text I can just start typing in the body section without having to change the 
selection to avoid deleting the signature.

Comment 1

14 years ago
I see this in 1.5 Final and also my current 1.6 build (a little old):
  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20031018
Couldn't find a dupe, so confirming.

This symptom is also true when Replying.  Updating summary.

Actually, I would think that the 'select' option makes no sense for Forwarding, 
and I'm surprised to see it being used.  Forwarding doesn't abide by either of 
the other two settings of that pref; nor, if you're using 1.6, does it abide by 
the "place my sig above/below the quote (top-replying)" preference.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: problem when forwarding when original message quoted and selected → 'select the quote' preference causes signature to be selected as well

Comment 2

14 years ago
I just discovered this is an old bug, duping.

*** This bug has been marked as a duplicate of 74779 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.