Wrong username next to "?" request

RESOLVED DUPLICATE of bug 250967

Status

()

Bugzilla
Attachments & Requests
--
critical
RESOLVED DUPLICATE of bug 250967
14 years ago
5 years ago

People

(Reporter: Vlad Dascalu, Assigned: myk)

Tracking

({dataloss})

2.17.1
dataloss

Details

(Reporter)

Description

14 years ago
http://bugzilla.mozilla.org/show_bug.cgi?id=223711 shows "jocuri: review?" next
to the 2nd attachment but
http://bugzilla.mozilla.org/show_activity.cgi?id=223711 shows that I haven't
made such a request.

Reproductible, I think:

1) Someone requests a review on a specific attachment.
2) Someone posts a comment regarding that attachment.

Expected results:

The original request for a review should remain attributed to the original user.

Actual results:

The original requester is overwritten by the last one.

(hmm, I seem to recall to see this bug but I can't find it).
(it would be kind of difficult for "Bugzilla" to realise based on the UI flags
if the desired action would have been to replace the original requester with the
current poster or not, but show_activity should be consistent with the current
status).

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 2.17.1
the info in the activity log is still correct, it's just presenting misleading
data to the user, but that's almost as bad.
Severity: normal → critical
Flags: blocking2.18+
Keywords: dataloss
Target Milestone: --- → Bugzilla 2.18
ok, newer bug, but I guess it has a patch.

*** This bug has been marked as a duplicate of 250967 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Flags: blocking2.18+
Resolution: --- → DUPLICATE
Target Milestone: Bugzilla 2.18 → ---
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.