If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Can not remove stored passwords

RESOLVED WORKSFORME

Status

SeaMonkey
Passwords & Permissions
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Volker Puttrich, Assigned: dveditz)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4.1) Gecko/20031008
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4.1) Gecko/20031008

Password Manager does not let me remove stored passwords with the following
functions:
-- Tools -> Password Manager -> Manage Stored Passwords
then
1. Selecting a password and then pressing [Remove]
or
2. Not selecting a password, but pressing [Remove All]

Symptoms:
Performing one of the actions stated above, removes the selected password from
the list or removes all passwords from the list. So far it acts like expected ...
After reopening the Password Manager, all the removed passwords are in the list
again. This can be verified by simply loading a Web page for which we've stored
a password and then removed it.

Regards,
Volker

Reproducible: Always

Steps to Reproduce:
1. Visit a Web site with a password field
2. Store the password with Password Manager
3. Remove the stored password or all stored passwords
4. Close Password Manager
5. Visit the Web site again (password field will be filled in)
6. (optional) Verify that the password is still in Password Manager

Actual Results:  
The password/passwords have been removed from the list visually, but not
internally. All removed passwords appeared again when reopening Password Manager.

Expected Results:  
It should remove the selected password or all passwords, depending on the action
(Remove or Remove ALL).

OS: Win2k with latest service pack and all other updates

Bug also appeares in Moz 1.3 (in every little detail)

Comment 1

14 years ago
WFM: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4.1) Gecko/20031008

Comment 2

14 years ago
Reporter, you may want to re-try this with a fresh profile.  In my experience,
installing a new version of Mozilla without wiping an old profile sometimes
result in these types of symptoms.
(Reporter)

Comment 3

14 years ago
Ok, I tried using a fresh profile, but with no reasonable difference. Instead 
something else happened. 

Of course the new profile had no passwords stored. I visited a page with a 
username/password dialog and stored the data in Password Manager.
Then I tried to remove it. Successfully!
I deleted the old (Default) Profile, so I only have one left and don't have to 
select one at startup.
At that time I've had the 'new' profile only, with no password stored (as I 
mentioned, I removed it). Well, after Mozilla started completely, I went back 
into Password Manager to see if it still has an empty list. I hope you can 
still follow me here... All the passwords from the 'old', 'deleted' profile 
have found their way into the 'new' profile!

I haven't tried to reproduce the behaviour yet, but will keep you informed as 
soon as I have experimented some more on that.

Comment 4

14 years ago
The way I would choose to be sure a profile is deleted would be to get in there
in the documents and settings\application data\mozilla folder and delete the
folder corresponding to the profile's name.  (You don't really have to delete
it.  You can just temporariliy relocate it, and put it back when you're done.)

At any rate, if you are saying that you can no longer reproduce the bug as
originally reported, good form is probably to mark this Resolved / Works for Me
and file a new bug for the other issue (unless you're pretty convinced that your
new issue is really an expression of the initially reported issue... which it
does not sound like it is, right?)

Comment 5

14 years ago
If you can still reproduce this with a new build, then please reopen
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.