keyboard scrolling fails - javascript error

VERIFIED DUPLICATE of bug 23401

Status

()

Core
Event Handling
P3
normal
VERIFIED DUPLICATE of bug 23401
18 years ago
18 years ago

People

(Reporter: dave thorn, Unassigned)

Tracking

Trunk
Other
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
On this page (and other), trying to use the keyboard to scroll the page causes
the following error (in the xterm):
JavaScript Error: TypeError: controller has no properties

However, I've now swapped windows a few times between that one and this and it
now scrolls properly  I've tried to narrwo it down, but it appears to happen
intermittently.

HTH
(Reporter)

Comment 1

18 years ago
Sorry, forgot to say the build: 1999082316

dave

Comment 2

18 years ago
Keyboard scrolling with arrow keys appears to work after pressing the tab key
when a page has loaded.

Comment 3

18 years ago
I see the same behavior on my Win98 box.
(Reporter)

Updated

18 years ago
Component: Browser-General → Event Handling
(Reporter)

Comment 4

18 years ago
I've looked at this some more and it appears that the focus isn't getting set
correctly.  When it's failing to scroll,the cursor is still flashing in the URL
bar, so trying to scroll in there won't scroll the page.

I guess focus should be set to the page (rather than the URL bar) when the page
is loaded/loading.

The reason this got reported as it did is because I had tried clicking in the
page to give that the focus, so it's not correctly setting the focus on the
mouseclicks.  Using the tab key does help sometimes, as it moves from the URL to
the page (and possibly a link), but it doesn't always work.

Changing component to Event Handling

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
*** This bug has been marked as a duplicate of 23401 ***

Comment 6

18 years ago
verified duplicate of 23401.  easy kill.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.