Raw HTML is displayed instead of the webpage.

VERIFIED INVALID

Status

()

Core
HTML: Parser
VERIFIED INVALID
15 years ago
15 years ago

People

(Reporter: Barry Knaggs, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

The above page is an automatic redirect from https://staffnew.shu.ac.uk/
prompting for username and password to be entered.  On this version of Mozilla
the raw html only is displayed and not the page.  Under Mozilla 1.2.1 the page
renders correctly.  The raw html is also displayed instead of the page using
Firebird version 0.7 - Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7.

Reproducible: Always

Steps to Reproduce:
1. Try to visit staffnew.shu.ac.uk using this version of Mozilla
2.
3.

Actual Results:  
The raw html is displayed instead of a rendered webpage.

Expected Results:  
Rendered the webpage.

Comment 1

15 years ago
*** Bug 224077 has been marked as a duplicate of this bug. ***

Comment 2

15 years ago
The host staffnew.shu.ac.uk does not appear to exist (or resolve to a public IP 
address).

However, from the description, I would guess that the web server is returning a 
page with Content-Type set to text/plain, causing the plain-text display you 
see (Internet Explorer will incorrectly 'guess' that the content is text/html 
instead).

Comment 3

15 years ago
Incorrect content-type + unreachable URL => INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
verified

btw: you can see the content-type if you load the page and use page Info (CTRL+I).
You can see it under "type"
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.