Add "Copy Link Text" to link context (right-click) menu

REOPENED
Unassigned

Status

()

--
enhancement
REOPENED
16 years ago
2 years ago

People

(Reporter: tyl2, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Oftentimes, I wish to copy the text of a link instead of or in addition to the
URL behind it. Currently, I have to position the mouse, usually from the end of
link to the beginning, and have to worry about accidentally scrolling, etc, when
the mouse slips. Right-clicking on a link only provides "Copy Link Location"
among other context menu options, but no "Copy Link Text," which is actually
strange behavior if you think about it, even though it's the norm. It's also
strange that if you select some normal text, then right-click on a link, you get
a "Copy" option but it pertains to the regular text instead.

Reproducible: Always

Steps to Reproduce:

Comment 1

16 years ago
This has been previously suggested and rejected.

*** This bug has been marked as a duplicate of 133661 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

2 years ago
(In reply to Bill Mason from comment #1)
> This has been previously suggested and rejected.
> 
> *** This bug has been marked as a duplicate of 133661 ***

The two bug are have difference.
Status: RESOLVED → REOPENED
Component: Event Handling → Menus
Ever confirmed: true
Product: Core → Firefox
Resolution: DUPLICATE → ---

Updated

2 years ago
Duplicate of this bug: 1346564

Comment 4

2 years ago
Even if it was truly a duplicate, closing a bug using a discussion from 14 YEARS AGO as the base for it is something surreal. I wonder how many issues are closed like this without being noticed.

@YF (Yang) , I'd like you to report the user Bill Mason  for this behavior for the proper staff to investigate his misuse of moderation privileges and revoke them in case there is a pattern for this.

Comment 5

2 years ago
Wait, I just realized that it was him who closed it 14 years ago, and you just reopened it this year. I'm sorry. I assumed that you wouldn't reopen something this issue.

Comment 6

2 years ago
this old.*
You need to log in before you can comment on or make changes to this bug.