after upgrading mozilla from 1.2 to 1.5 (and Firebird 0.7) all of the first letters in words on yahoo were corrupted.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: scott.didriksen, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

I upgraded from Mozilla 1.2 to 1.5 and now the first letter of every word is
corrupted when I go to most sites (yahoo the main one). I installed Firebird 0.7
and it has the same problem. I upgraded another system and it does not have this
problem. I am using Red Hat 9.0 on both systems. I tried different fonts and
sizes with no success.

Reproducible: Always

Steps to Reproduce:
1. downloaded 1.5 and installed it on Red Hat 9.0
2. I started and went to http://www.yahoo.com
3. Display came up corrupted.

Actual Results:  
First letter in every word is a strange character (S is now a .)

Expected Results:  
Display words correctly.

Used the default theme in all cases.
A screenshot would be nice...
Are you using an xft build?  See about:buildconfig
(Reporter)

Comment 3

15 years ago
Created attachment 134413 [details]
Screen shot of Yahoo web page with Firebird 0.7

Looks exactly the same with Mozilla 1.5.

Comment 4

15 years ago
Seems like 0x20 (Space) is subtracted from the value of the first char,
so Y 0x59 gets 9 0x39, S 0x53 gets 3 0x33, A 0x41 gets ! 0x21, 
seems to be like a touper(), or was it _toupper(), which should be used only on
lowercase chars, applied to uppercase chars.
Do you use extensions on both browsers?
Hmm.. yeah, all the lowercase chars on that page have been uppercased.  I just
tested, and text-transform:uppercase does NOT have this bug in Mozilla.  So
something else is doing the uppercasing...
For ASCII text (like here) we use the OS toupper() function to implement the
text-transform, which would point to this being a libc bug on the affected
system.  But we were doing that in 1.2 as well...  drepper, do you have any
ideas what's up here?

Comment 7

15 years ago
If the code is correct there are only two possibilities: compile problem or
corruption of the locale data.  The latter would show up also in other programs
if the same locale is used.
I'd rather avoid using locale-sensitive functions, though, since we want to
treat web content the same way everywhere.  (I'm surprised toupper doesn't
behave differently in Turkish locale, although it seems not to.)
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Anyone still seeing this on a recent build? (SeaMonkey 1.1.9 or 2.0a1pre, Firefox 2.0.0.14 or 3.x) If you do, please paste your useragent string (found after "Build ID" on the page obtained by typing "about:" without the quotes in the URL bar then hitting Enter)
Assignee: layout.fonts-and-text → nobody
QA Contact: ian → layout.fonts-and-text
wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.