registerid.rbc.com - Proceed button broken on this page. Works fine in IE6 and Netscape 4.7x

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
4 years ago

People

(Reporter: swright, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.5) Gecko/20031007

Have tested with Mozilla 1.4 and 1.5, with clean profile, on NT and Win2K.
Proceed button does nothing, but works as intended in both NS 4.7x and IE6.
Cancel button does work as intended.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Expected Results:  
Proceeded to https://registerid.rbc.com/rbcesec/register.jspx
The page has the following code:

<input type="submit" name="proceed" id="proceed" value="Proceed" disabled>

And the following script:

function disable_enable(theFormElement)
{
	// if the surfer is using IE 4 or above
	if (document.all)
	{
		theFormElement.disabled=!theFormElement.disabled;			
	}
}

This whole mess works in IE, since IE implements the proprietary document.all.
It works in NS4 because NS4 does not support the "disabled" attribute on form
controls.

But in Mozilla the form control is disabled and the script doesn't reenable it
when you tick the checkbox (since Mozilla does not implement document.all).

Evang.  Shawn, it would help if you would mail the site maintainers and complain
about the problem...
Assignee: general → english-other
Status: UNCONFIRMED → NEW
Component: Browser-General → English Other
Ever confirmed: true
OS: Windows NT → All
Product: Browser → Tech Evangelism
QA Contact: general → english-other
Hardware: PC → All
Version: Trunk → unspecified

Updated

15 years ago
Summary: Proceed button broken on this page. Works fine in IE6 and Netscape 4.7x → registerid.rbc.com - Proceed button broken on this page. Works fine in IE6 and Netscape 4.7x
WFM
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.