Setting "review+" flag sends flag setter mail if there was no "review?" flag

RESOLVED FIXED in Bugzilla 2.20

Status

()

RESOLVED FIXED
16 years ago
6 years ago

People

(Reporter: bzbarsky, Assigned: LpSolit)

Tracking

2.20
Bugzilla 2.20

Details

(Whiteboard: [blocker will fix])

VERSION:  Whatever bugzilla.mozilla.org runs

PROBLEM DESCRIPTION:

If I set "review+" on a patch which had no "review?" flag, I get an email
telling me that I fulfilled my own request (which I never made, of course).

I know I set the flag.  I don't need to get mail about it.  I certainly don't
need misleading mail about it....

I can't recall this ever happening before, and I'm pretty sure I've encountered
this exact situation after the new request system was in place.  Did the
mozilla.org version of bugzilla get updated recently?

See also bug 223420 and bug 214179 for similar issues...

Comment 1

16 years ago
Yeah, I've seen this myself.
Hmm, this might be because of bug 183788, the fix for which I recently applied
to b.m.o.
Note that the changelog for the bug (eg
http://bugzilla.mozilla.org/show_activity.cgi?id=180049) shows me changing the
flag from (in this case) "superreview?" to "superreview+" whereas in reality I
changed it from nothing to "superreview+" (note that there is no earlier change
to set "superreview?").
Er, ignore comment 3.  I just can't read a change log, apparently.. ;)
(Assignee)

Updated

13 years ago
Assignee: myk → LpSolit
Depends on: 266147
OS: Linux → All
Hardware: PC → All
Whiteboard: [blocker will fix]
Target Milestone: --- → Bugzilla 2.20
Version: unspecified → 2.20
(Assignee)

Comment 5

13 years ago
*** Bug 320043 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

13 years ago
fixed!
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.