Text fields in mail news wizard only display first few characters typed

VERIFIED FIXED in M13

Status

SeaMonkey
MailNews: Message Display
P3
major
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Syd Logan, Assigned: kinmoz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Linux, 12/22 M13 tip of tree, mozilla build.
I was trying to set up a profile for mail news on my home machine. Typing in
server names, users names, etc. I would only ever see the first 1 or two
characters typed. Dragging an xterm or some other app window over the dialog
would cause the entire text to display.

Updated

18 years ago
Assignee: phil → alecf
QA Contact: lchiang → nbaca

Comment 1

18 years ago
Account Manager -> Alec.

Updated

18 years ago
Assignee: alecf → buster

Comment 2

18 years ago
editor/paint bug -> buster

Updated

18 years ago
Assignee: buster → kin

Comment 3

18 years ago
linux-only paint bug.  assigned to kin, cc akkana and pav.

Updated

18 years ago
Target Milestone: M14

Comment 4

18 years ago
setting this to m14
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

18 years ago
Accepting bug.

Updated

18 years ago
Target Milestone: M14 → M13

Comment 6

18 years ago
received some additional data on just how annoying this on is -- the perception
that the editor isn't working due to the lack of visual feedback -- so, I'm
setting this one back to m13.

Comment 7

18 years ago
The same behavior happens in HTTP password authentication dialogs; so this may
be not just a MailNews problem.

Eg: point your browser to http://www.dmoz.org
Click on "Editor Login"
Password dialog comes up, where only first character of name and password are
displayed.
(Assignee)

Comment 8

18 years ago
*** Bug 22919 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

18 years ago
The damage rects are being recorded by each nsWindow. The problem seems to be
that the Gtk implementation of nsWindow::Update() only updates it's associated
native window. The view manager assumes that updating a window will also
force/flush any pending updates for child windows too.
(Assignee)

Comment 10

18 years ago
Created attachment 4172 [details] [diff] [review]
Proposed fix.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

18 years ago
Checked in fix:

    mozilla/widget/src/gtk/nsWindow.cpp   revision 1.227

r=blizzard@redhat.com,pavlov@netscape.com

Updated

18 years ago
Blocks: 14845

Updated

18 years ago
No longer blocks: 14845

Comment 12

18 years ago
This problem was noted in bug 14845, which was reopened.  14845 is now marked as
depends on this bug and that bug should be retested when this is tested.

Comment 13

18 years ago
Using linux build 2000011313m13 this is working OK.  I tested this scenario
along with the scenario in 14845 and all text field entries are working.  Just
to double check, syd could you please confirm yours is fixed too.

Comment 14

18 years ago
Per Esther's claim that this bug is fixed, I am verifying this bug. If the 
problem occurs again then please reopen.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.