%%BLURB%% appears intermittently on home page

VERIFIED DUPLICATE of bug 246888

Status

www.mozilla.org
General
P1
normal
VERIFIED DUPLICATE of bug 246888
14 years ago
5 years ago

People

(Reporter: Dawn Endico, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
since my checkin to add alternate templates i've noticed a couple times where
the main /index.html page wasn't munged properly.

The first time, the page was wrapped, like a normal file, and the news blurb
wasn't substituted. The second time, i had added index.html to /NOWRAP so the
only problem was the news blurb.

the wrapping process always wraps /index.html first. maybe something is messing
up and wrapping the file again later on with the normal wrapped files, and
overwriting the good one.

In addition, when I noticed this problem i typed 'make' in mozilla-org and
the entire tree rebuilt because files in the output directory were older than
various template files (and wrap.pl?). Not sure what's touching the template
files. (dostage?) Last night i looked at a file that was triggering a mass
rebuild and its time stamp was a few hours off.

rebuilding the tree fixes the first problem, although not always on the
first try.


this should be fixed before merging branch with the trunk but not necessarily
before rc1 since its intermittent and i don't know how to reproduce
(Reporter)

Updated

14 years ago
Priority: -- → P1
yes, I experienced this problem last night as well.  quite unsettling when it
happens.  we definitely want to get to the bottom of this.

Comment 2

14 years ago
Endico, the %%var%% is not working in
http://www.mozilla.org/projects/thunderbird/ either
(Reporter)

Comment 3

14 years ago
This happened again shortly after i checked in the new home page in 
to the trunk. The first build worked fine but later when I added a
new item to news.html, the blurb substitution failed again. (or maybe
it was already broken by then. i didn't look at the site right before
the checkin.)

The problem with the thunderbird page was fixed by touching the page
in the html directory (to force a rebuild) and typing make. This happened
before i checked in the new blurb to news.html and site variables
on other pages worked just fine.

I am completely unable to reproduce the bug. It seems to be associated
with mozilla-org/html/VARIABLES (or sometimes files in mozilla-org/tools
or template files) getting mysteriosuly touched and causing a rebuild of
the entire tree.

To fix the problem, 

touch /data/www/stage-docs/mozilla-org/html/news.html
touch /data/www/stage-docs/mozilla-org/html/index.html
cd /data/www/stage-docs/mozilla-org
make
grep BLURB /data/www/stage-docs/mozilla-org/output/index.html
(if this is empty then continue)
cp /data/www/stage-docs/mozilla-org/output/index.html /data/www/docs

Updated

14 years ago
QA Contact: imajes → stolenclover

Comment 4

14 years ago
has this been fixed?
reassigning endico's bugs to default owner
Assignee: endico → mozilla.webmaster

Comment 6

13 years ago
Has this been resolved with the new website?

*** This bug has been marked as a duplicate of 246888 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.