Can't paste bookmarks into an empty folder, not even when icon looks open

RESOLVED DUPLICATE of bug 211516

Status

RESOLVED DUPLICATE of bug 211516
15 years ago
14 years ago

People

(Reporter: doom, Assigned: p_ch)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

Pretty frequently, when using the Bookmark Manager, I look
at a group of adjacent bookmarks on a given topic and decide
I'd like to group them in a folder. 

I'm not a mouse-oriented person, so I try and do this
entirely with keyboard commands, and I think there's a gap
in the process that shouldn't be there. 

I can create a new folder: 
   Alt-F N W 

I can select a group of bookmarks: 
  shift-downarrow 

I can move them to the clipboard: 
  Ctrl-X

But I can't find a way to get Ctrl-V to paste them *into*
the newly created folder. 

If I just cursor to the folder, and do a Ctrl-V, then end up 
pasted adjacent to the folder (probably this is what should happen).

If I cursor to the folder, then do a right-arrow, the folder 
icon changes from a closed to an open folder, but if you do 
a Ctrl-V at that point, the bookmarks still end up pasted
next to the folder, instead of inside of it.  This seems
really counter-intuitive... I would definitely call this a bug.

The workaround is to reach for the mouse, and to drag at
least one bookmark into the folder.  When it's not empty,
it's possible to paste more bookmarks into it: this is a
problem that arises solely with a new, empty folder.

I've described the problem in terms of keyboard commands,
but I see it's also reproducible using the mouse
(double-click on folder to get it to open, then use right
click menu to do the "paste").  If you were on the mouse
already though, you probably wouldn't care about this much.


Reproducible: Always

Steps to Reproduce:
1. Create new folder (Alt-F N F)
2. Select some bookmarks, move to clipboard (shift-downarrow, Ctrl-X)
3. Cursor to new folder, do right arrow to open it
4. Paste (Ctrl-V)

Actual Results:  
Bookmarks always end up next to folder, not inside it. 


Expected Results:  
When pasting into an "open" folder, bookmarks should end up inside the folder.

Comment 1

15 years ago
dupe of bug 211516
Summary: Can't paste bookmarks into an empty folder, not even when icon looks open → Can't paste bookmarks into an empty folder, not even when icon looks open

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 211516 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.