Tabbing on checkbox with <label> attached.

RESOLVED DUPLICATE of bug 142898

Status

()

--
trivial
RESOLVED DUPLICATE of bug 142898
15 years ago
15 years ago

People

(Reporter: srinivas_rc, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

Hi,

   I had a page in which i have labels and corresponding check boxes.
   For usability, in lot of sense mozilla is a lot better than Internet Explorer.

   For this one, it was different.  When i press tab key, my curson or say the
ligh selection box (of dotted line) as on the check box rather than on the text.
 On Internet Explorer it seems to be working fine.

   I am sure it may not be called as a bug.  But surely a enhancement that can
help a lot to power users.

Thanks

Srini
--

Reproducible: Always

Steps to Reproduce:
1. Create a checkbox
   with <label> tag for label and linking it to input tag.
2. Include this in the form.  tab, tab.. and see


Actual Results:  
Cursor was on check box rather than the text

Expected Results:  
cursor should be on the 'Text' or 'Label'.  

I hope it is a simple UI problem.

Comment 1

15 years ago
->Layout/Form Controls
Testcase forthcoming
Assignee: general → form
Component: Browser-General → Layout: Form Controls
Keywords: testcase
QA Contact: general → ian
Hardware: All → PC

Comment 2

15 years ago
Created attachment 134509 [details]
testcase
(Reporter)

Comment 3

15 years ago
Created attachment 134522 [details]
One more test case...

The previous attachment does not work in both IE and Mozilla.
Current attachment works good in IE and not working in Mozilla.

May be IE has a bug with 'input' field embedded with <label> and </label>

So i thought may be this will help.

Comment 4

15 years ago
I don't know how "working" and "not working" is defined, but my testcase works
the same for me in Mozilla 20031029 and IE6 PC/Win2000 -- tabbing puts focus on
the checkbox.

I don't see what problem is being reported anyway, since in your description you
say Mozilla's behavior is better but then you say the current behavior "works
fine" in IE -- implying you think Mozilla's behavior is wrong.

Severity -> Trivial, since no matter where the tab goes to, you are in a
position to toggle the checkbox using the keyboard anyway.

Reporter, you might want to define exactly what you think the problem is since
your description contradicts itself.
Severity: normal → trivial
(Reporter)

Comment 5

15 years ago
I work as a Tech. Architect and also interfacce expert for web interface system
(internal and not for external websites).

Cursor movement generlly drives how super users use it using the key board.  I
agree that it works perfectly i.e. toggle, and it is not critical.  But what is
highlighted generally makes it very easy for power users(who uses keyboard
extensively) for maximum output within minimum time.  Check the second
attachment in IE and you will know what i am saying.

http://bugzilla.mozilla.org/attachment.cgi?id=134522&action=view


Also, this is very much cler in checkbox case, as checkbox itself is very small
and so cursor is not clearly visible. Making the corresponding label highlighted
(with dashed box) may be more user friendly.

You can highlight both checkbox and label which will also work.

Again this can be extended to all kinds of input fields, whose label is linked
using <label> statement.  I know that it is for screen readers, accessibility,
but highling some way the label makes data entry very easy.

my 2 cents.

*** This bug has been marked as a duplicate of 142898 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.