nyse.com - CGI HTML output served as text/plain

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
P2
normal
RESOLVED WORKSFORME
14 years ago
3 years ago

People

(Reporter: Kevin Goerlitz, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

The 1.5 build of Mozilla is not formatting some HTML pages.  Instead, the page
is displayed as plain text.  This worked correctly in Mozilla 1.4.


Reproducible: Always

Steps to Reproduce:
1. Go to http://www.nyse.com
2. Enter IBM (or any stock symbol) in the Quick Quote text box
3. Click on the Quick Quote button


Actual Results:  
The CGI generated page is displayed as plain text in the frame.

Expected Results:  
Formatted the HTML page in the frame.

Comment 1

14 years ago
The data is being served as text/plain, so Mozilla shows it as plain text.  It
does the same thing in 1.4.

The fix is for the server administrator to correct the server setting.

->TE
Assignee: parser → english-us
Status: UNCONFIRMED → NEW
Component: HTML: Parser → English US
Ever confirmed: true
Priority: -- → P2
Product: Browser → Tech Evangelism
QA Contact: english-us
Summary: HTML page is displayed as plain text → nyse.com - CGI HTML output served as text/plain
Version: Trunk → unspecified

Comment 2

14 years ago
Actually the data returned by the server contains two Content-Type fields and
some garbage. I suppose the problem was not present in Mozilla 1.4 because it
interprets the first received field whereas Mozilla 1.5 interprets the second one.

I already sent a mail to the webmaster (before looking to bugzilla), but I
haven't received any answer :-(


[pc:~]$ telnet www.nyse.com 80
Trying 129.33.133.232...
Connected to 129.33.133.232.
Escape character is '^]'.
GET http://www.nyse.com/cgi-bin/ny_quote?sym=ibm HTTP/1.1

HTTP/1.1 200 OK
Date: Sat, 01 Nov 2003 21:20:48 GMT
Server: IBM_HTTP_Server/1.3.12.6 Apache/1.3.12 (Unix)
<p>inside get_newsinfo - symdata.nwtick = IBM </p><p>about to leave
get_newsinfo - num_headline = 5</p>Content-type: text/html
Connection: close
Content-Type: text/plain

<HTML>
<HEAD>
<TITLE>NYSE</TITLE>
<SCRIPT language="javascript">
<!--
function open_window(url,name,features){
popup=window.open(url,name,features);
if (window.focus)
popup.focus();
}

...

Comment 3

14 years ago
It seems that the problem has been fixed by the webmaster of this site, as it is
now working correctly.

This bug could now probably be closed.

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.