Bookmarks panel doesn't focus bookmarks tree when selected

RESOLVED FIXED

Status

SeaMonkey
Bookmarks & History
--
minor
RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: Pierre Chanial)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Steps to reproduce problem:
1. If the sidebar is closed, open it
2. Select the history panel
3. Select the bookmarks panel

Expected result: Both panels focus their respective tree

Actual result: Bookmarks panel does not focus its tree

Additional information: Caused by the BookmarksTree.xml landing
(Reporter)

Comment 1

15 years ago
Created attachment 134537 [details] [diff] [review]
Proposed patch

The sidebar loader doesn't know how to focus anonymous nodes,
so get the bookmarks-tree to move the focus to the anonymous tree.
(Reporter)

Comment 2

15 years ago
Comment on attachment 134537 [details] [diff] [review]
Proposed patch

This was the one which I meant to ask your review, perhaps the other request
might have been by mistake.
Attachment #134537 - Flags: review?(p_ch)
(Assignee)

Comment 3

15 years ago
Comment on attachment 134537 [details] [diff] [review]
Proposed patch

np, but this patch depends anyways on the one in bug 50223
Attachment #134537 - Flags: review?(p_ch) → review+
(Reporter)

Comment 4

15 years ago
Comment on attachment 134537 [details] [diff] [review]
Proposed patch

pch, I don't think that this is dependent, because bug 50223 already works for
the history sidebar.
Attachment #134537 - Flags: superreview?(alecf)

Comment 5

15 years ago
Comment on attachment 134537 [details] [diff] [review]
Proposed patch

sr=alecf
Attachment #134537 - Flags: superreview?(alecf) → superreview+
(Reporter)

Comment 6

15 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.