segfault on startup - gcc2.9x no longer supported

RESOLVED INVALID

Status

RESOLVED INVALID
15 years ago
9 months ago

People

(Reporter: urkle, Unassigned)

Tracking

1.8 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 Galeon/1.2.11 (X11; Linux i686; U;) Gecko/20030703
Build Identifier: http://dag.wieers.com/packages/mozilla-firebird/

on a Redhat 7.3 system (Dag's RH 7.3 build) firebird created the .phoenix
directory and default profiles in there. then segfaults..
I have tried moving all of my plugins out of the way, and the same thing occurs...

Reproducible: Always

Steps to Reproduce:
1.run MozillaFirbird

Actual Results:  
It fails to start and segfaults

Expected Results:  
Firebird to display.
(Reporter)

Comment 1

15 years ago
Created attachment 134543 [details]
stack trace from running MozillaFirebird-bin

I set the environment variables
MOZILLA_FIVE_HOME and LD_LIBRARY_PATH
and ran nohup strace ./MozillaFirebird-bin

Comment 2

15 years ago
Same thing happens on my Suse Linux 9.0 with MozillaFirebird 0.6.1,
MozillaFirebird 0.7 and Firefox 0.8 (and Thunderbird 0.5, btw).

CPU: Athlon 2100+

Comment 3

15 years ago
I also had this problem, with a localized German version of firefox.

This may actually be a problem with the distributed tarball.
There are some files in this tarball that are not readable
for "normal" users (don't know why certain people experience this
and others don't). I put an "strace" in the run-mozilla.sh script,
and it showed that some .jar files in the chrome subdirectory
were unreadable.
I changed the permission (a la "chmod 644 *.jar"), restarted firefox,
and VOILA: a browser window appeared for the first time !

Comment 4

15 years ago
Unable to reproduce with 20040429 Firefox build on Red Hat enterprise linux 3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

15 years ago
I am still getting this segfault.. 
If i compile with GCC 3.2 it works fine.. but if I use the stock RH 7.3 gcc 2.96
it segfaults.

And as RHEL3 does not have a GCC 2.96 family compiler, of course the bug can't
be reproduced there..

This also happens with Mozilla 1.6.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 6

15 years ago
I'm not sure if we support this compiler or not. Either way, this belongs in
Build Config. 
Assignee: firefox → bryner
Component: General → Build Config
QA Contact: asa
Can't really do much with this until someone does a build with debugging symbols
on 2.96 and posts a stack trace of the crash.

Comment 8

15 years ago
I'm indeed incapable of making a debug build, but an strace put in the start
script produces output that is downloadable from
aktuell.coolmule.de/ff_strace.gz. If you are interested in the last 100 lines of
it only, you can download aktuell.coolmule.de/ff_strace_tail
This happened to me using version 0.9.1

Comment 9

14 years ago
From the GCC team: 
(http://gcc.gnu.org/ml/gcc-announce/2000/msg00003.html)
"It has come to our attention that some GNU/Linux distributions are
currently shipping with ``GCC 2.96''.

We would like to point out that GCC 2.96 is not a formal GCC release nor
will there ever be such a release.  Rather, GCC 2.96 has been the code-
name for our development branch that will eventually become GCC 3.0."

This is probably a bug in GCC 2.96 instead of Firefox/Firebird.

Comment 10

14 years ago
Firefox 1.0PR and 1.0 work for me now. Thunderbird 1.0 still crashes. I thought
about downloading the sources but the thunderbird page says that it's no use
without experience in large C/C++ projects.

Comment 11

14 years ago
(In reply to comment #10)
> Thunderbird 1.0 still crashes. I thought
> about downloading the sources but the thunderbird page says that it's no use
> without experience in large C/C++ projects.

http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/1.0/source/
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 13

13 years ago
The problem still remains.

stefan@ds9 ~ $ thunderbird --version
(null) Thunderbird 1.0.6, Copyright (c) 2004 mozilla.org
stefan@ds9 ~ $thunderbird
No running windows found
Removing /home/stefan/.thunderbird/y577xdxw.default/compreg.dat leftover from
older thunderbird
Removing /home/stefan/.thunderbird/y577xdxw.default/XUL.mfasl leftover from
older thunderbird

(thunderbird-bin:18231): Gdk-WARNING **: gdk_property_get(): length value has
wrapped in calculation (did you pass G_MAXLONG?)
*** loading the extensions datasource
*** ExtensionManager:_updateManifests: no access privileges to application
directory, skipping.

(thunderbird-bin:18231): Gdk-WARNING **: gdk_property_get(): length value has
wrapped in calculation (did you pass G_MAXLONG?)
*** loading the extensions datasource
*** ExtensionManager:_updateManifests: no access privileges to application
directory, skipping.
/usr/libexec/mozilla-launcher: line 116: 18231 Speicherzugriffsfehler  "$mozbin"
"$@"
thunderbird-bin exited with non-zero status (139)

I'm more than willing to use thunderbird, but what can I do? If there's no one
to guide me how to locate the bug I won't ever find it.

Comment 14

13 years ago
(In reply to comment #13)
> The problem still remains.
> 
> stefan@ds9 ~ $ thunderbird --version
> (null) Thunderbird 1.0.6, Copyright (c) 2004 mozilla.org

and in Thunderbird 1.5 beta 2 ? (which is what the auto-resolve mail asked)

Comment 15

13 years ago
Sorry. Same or similar problem:

stefan@ds9 ~ $ /usr/local/thunderbird-1.5b2/thunderbird
*** Item Installed via directory addition to Install Location: app-global Item
ID: talkback@mozilla.org, attempting to register...
*** Item Installed/Upgraded at Install Location: app-global Item ID:
talkback@mozilla.org, attempting to register...
*** ... success, item is compatible
*** Item Installed via directory addition to Install Location: app-global Item
ID: {972ce4c6-7e08-4474-a285-3208198ce6fd}, attempting to register...
*** Item Installed/Upgraded at Install Location: app-global Item ID:
{972ce4c6-7e08-4474-a285-3208198ce6fd}, attempting to register...
*** ... success, item is compatible
*** Datasource: Update Started
*** Datasource: Addon Update Started: talkback@mozilla.org
*** Datasource: Addon Update Ended: talkback@mozilla.org, status: 32
*** Datasource: Addon Update Started: {972ce4c6-7e08-4474-a285-3208198ce6fd}
*** Datasource: Addon Update Ended: {972ce4c6-7e08-4474-a285-3208198ce6fd},
status: 32
*** Datasource: Update Ended
/usr/local/thunderbird-1.5b2/run-mozilla.sh: line 131:  8127
Speicherzugriffsfehler  "$prog" ${1+"$@"}
Moving up to Core :: Build Config since the latest comments deal with Thunderbird.
Assignee: bryner → nobody
Component: Build Config → Build Config
Product: Firefox → Core
QA Contact: asa → build-config
Version: unspecified → 1.8 Branch
Stefan,
Can you please try with Thunderbird 1.5 RC1? You can get it from [http://www.mozilla.org/products/thunderbird/releases/1.5.html].

Comment 18

13 years ago
Sorry that it took so long. I just downloaded and tried thunderbird-1.5.tar.gz with the same result:
stefan@ds9 ~ $ /usr/local/thunderbird-1.5/thunderbird
/usr/local/thunderbird-1.5/run-mozilla.sh: line 131: 26306 Speicherzugriffsfehler  "$prog" ${1+"$@"}
CC'ing bsmedberg to check out this bug

Comment 20

13 years ago
BTW, the Netscape feedback agent appeared right after the crash. I filled in my email address and this bug's number into the form. Maybe the feedback provides some more useful information.

Comment 21

13 years ago
Incident ID: 14245498 
Stack Signature null 
Product ID Thunderbird15 
Build ID 2005120113 
Trigger Time 2006-01-21 12:09:46.0 
Platform LinuxIntel 
Operating System Linux 2.6.14-gentoo-r5 
Module  
URL visited  
User Comments see BUG 224260 
Since Last Crash 0 sec 
Total Uptime 0 sec 
Trigger Reason SIGSEGV: Segmentation Fault: (signal 11) 
Source File, Line No. N/A 
Stack Trace  

-- there's really no stack :( --

fwiw, you have one other crash (flash):
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=13777513

Comment 22

13 years ago
Sorry if I do not get the point of comment #21. Ok there's no stack trace. I didn't know the contents of the talkback report, I didn't even know the reports were public. The given link doesn't get me to a valid talkback report.

I consider a bug of that kind major but it is not even assigned to someone. It is always reproducable and occurs in the binary distribution. Isn't there something like "replace this file by that file" or "add command line parameter soandso" to get some debugging information?

Would it help to open a new bug to get more attention? I don't hope so. Please instruct me what to.
(Reporter)

Comment 23

13 years ago
Are people still trying to us gcc 2.96 to compile firefox?  For me this is no longer an issue as I finally upgraded my redhat 7.3 system to fedora core 4.  If the mozilla foundation is not going to support gcc 2.96 then this bug should probably be closed "wontfix"
(In reply to comment #23)
> Are people still trying to us gcc 2.96 to compile firefox?  For me this is no
> longer an issue as I finally upgraded my redhat 7.3 system to fedora core 4. 
> If the mozilla foundation is not going to support gcc 2.96 then this bug should
> probably be closed "wontfix"
> 

Current builds of Fx2 (1.8.1.x Branch) are compiled with gcc 3.3.2, Sm2 (1.9 Trunk) with gcc 4.1.2. (both according to about:buildconfig)

My openSUSE 10.3 comes with gcc 4.2.1.

I expect this bug will be resolved WONTFIX indeed.

Comment 25

11 years ago
We no longer support compiling with gcc 2.9x. I think, rather than resolving this INVALID, we should make a configure check to make it perfectly clear what's going on. Patches accepted.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: segfault on startup → segfault on startup - gcc2.9x no longer supported
Bug against ancient, no-longer-supported compiler and Firefox version. Closing.
Status: NEW → RESOLVED
Last Resolved: 15 years ago2 years ago
Resolution: --- → INVALID

Updated

9 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.