Cannot insert cursor when I add a reciptent(To, Cc, Bcc.. any of them) after deleting receiptent(To.) which appeared first time of composing new message.

RESOLVED DUPLICATE of bug 215494

Status

MailNews Core
Composition
--
minor
RESOLVED DUPLICATE of bug 215494
15 years ago
10 years ago

People

(Reporter: WonYong Jung, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030718

In composing message (new, reply, forwarding.. any of them), cursor does not
appear to input field which is for e-mail address when I once delete a item
'To.' and click blank to add new receiptent(cannot insert Subject also).
A new item was added but cursor did not appeared and cannot insert any charactor.

To resolve this problem, I have to click mail body area to make cursor appear
first, after that I can insert string to receiptent input field (or Subject
input field). 

This is occured in thunderbird 0.2 also.


Reproducible: Always

Steps to Reproduce:
1. Click Compose icon and open a new mail composing window.
2. 'To.' item is activated and cursor is in input field to insert e-mail address.
3. Press backspace key to make disappear 'To.' item.
4. Click blank area of receiptents and make a new item.
5. Cursor not appear in input field (Subject input field also).


Actual Results:  
Can not insert any e-mail address and Subject.

Expected Results:  
Each time of adding new receiptent, cursor must be appeared however receiptent
item was deleted. I think.

Comment 1

15 years ago
I don't entirely understand the bug report.  I am testing with 1.5 Final; I 
would recommend you upgrade, since you appear to be using a 1.5a (alpha) build.

When you say "Press backspace key to make disappear 'To.' item", what exactly is 
going on here?  Is there only one address field, or have you already created 
multiple ones?  Is there text in that address field, or is it blank?

Your report seems to say that you get a compose window where none of the lines 
for addresses have a "to:" or "CC:" or any prefix header; that is, all four 
lines are completely blank.  Is that the case?  I cannot reproduce this.

In 1.5 Final, Backspace does nothing if there is only one address field and it 
is empty.  Backspace will remove the prefix from a blank field only if at least 
one other field has a prefix (even if that other field is blank).

I do see a small problem where removing a blank field with backspace causes the 
caret (what you call the cursor) to stop blinking; usually it becomes invisible 
but sometimes it displays as an unblinking line. However, it is still possible 
to type characters in the field.
(Reporter)

Comment 2

15 years ago
If you set 'Reply-to Address' which is in Preference->Mail&Newsgroups Account
Settings->[Your Account Name]->Identity Area(->Reply-to Address), A new compose
window have two receiptents. One is Reply-To, the other is To that is blank.
And caret is blink in input field of To.
If you make mistype and want to clear all of that, you can hold backspace until
all charactors are deleted. In this case, To will be disappeared and you have to
click receiptents field to add new To item. After adding new To item, caret is
not in input field and can not insert any charactor.

This problem can be seen if you make mail to have multiple receiptents.
I can reproduce this problem mozilla which is 1.5a on Winodws XP Pro (English,
Japanese), Windows HomeEdition(Japanese).

Thanks.

Comment 3

15 years ago
I tried replicating that.  I set up with an automatic Reply-to:, and hit 
backspace immediately on opening the new window, so the To: field disappeared.
I then hit Return, and a new address field opened that defaults to Reply-to:.
I clicked on the dropdown and selected To:, and it changed.  

At this point, the caret is not visible -- but that's because the focus is on 
the dropdown.  If I type Tab, or if I click on the address field, the focus 
shifts as expected, the caret appears, blinking, in the address field.

The indication that the focus is on the dropdown is subtle in the Modern theme, 
and nonexistent in Classic -- see bug 178637. Also, bug 58921 might relate to 
your problem.
(Reporter)

Comment 4

15 years ago
>I tried replicating that.  I set up with an automatic Reply-to:, and hit 
>backspace immediately on opening the new window, so the To: field disappeared.
>I then hit Return, and a new address field opened that defaults to Reply-to:.

-> This problem is in case click to add new To:. Not Return(Enter) key.
In the case of using Return key, it works correctly both of classic theme and
modern theme. Please try click to add new one after To: field disappeared.
(Please try use mouse only to move caret forcus, add item, change option just
like dropdown menu. )

Thanks.

Comment 5

15 years ago
OK, I tried clicking to create a new To: field, after causing the original To: 
field to disappear using backspace.  Clicking creates a new Reply-To: field, 
with the caret blinking next to the field.  Using the mouse to open the dropdown 
and selecting To: sets the header to "To:" as expected and keeps the focus on 
the dropdown; the caret is not blinking in the field.  If I click on the field, 
the caret starts to blink.  Alternately, if I tab to the field, the caret 
appears, blinking, in the field.  In other words, I see no difference between 
hitting Return and clicking to create a new header, after erasing the original 
To: field.

Using the Modern theme, when you get into the problem state: does the dropdown 
appear identical (in color) to the Reply-To: dropdown directly above it?  Or is 
it darker?
(Reporter)

Comment 6

15 years ago
I found that this problem is appear only my computers (or set by me).
The other computers are not occured. I think it is my fault because I reproduce
this problem only three computers that I have use. 
I'll try to find what cause this problem. 

Can you help me how can I close or cancel this issue? Resolve bug? 

Thanks for your attention. 

Comment 7

15 years ago

*** This bug has been marked as a duplicate of 215494 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.