Icons appear corrupt with nvidia 52.16 driver (and later) - works again with 56.64 (and later)

RESOLVED WORKSFORME

Status

defect
--
minor
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: quitchy, Assigned: jdunn)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

Reporter

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

All the Mozilla Firebird icons appear corrupt on my toolbar and around the
browser, whether in large or small mode.  All buttons are slight overwritten
with bits of words from the menu (like File) and vertical lines close to the
side of the icons.  This is true for all Navigation buttons, the top right
Mozilla homepage button and the webpage icon for this site.  No other website
icons have been affected yet.  The issue remains whether I use the official 0.7
release or the latest nightly build.  I have on an nVidia Vantra using the
official 52.16 drivers.  Nothing besides Firebird appears to be effected.  I
have cleared the icon cache without effect.

Reproducible: Always

Steps to Reproduce:
1. Load browser
Actual Results:  
Icons appear corrupt

Expected Results:  
Icons should appear as intended without lines and text across them

Comment 1

16 years ago
WFM, Firebird nightly trunk build 20021030 on Win2k (Mozilla/5.0 (Windows; U;
Windows NT 5.0; en-US; rv:1.6a) Gecko/20031030 Firebird/0.7+).
Have you tried with a fresh profile (i.e., temporarily stomping your profile,
and seeing if the problem persists)?  That has resolved crazy problems with the
UI for me in the past.

Comment 3

16 years ago
Can confirm bug, Running XPSP1, bug is reproducable on all builds 
including .7 .7.1 and latest nightly. Attached screenshot shows corruption, 
have also tried -P switch with no success.
Confirming based on comment 2 and comment 3.

P Cocker, Koobs, which graphic card and which driver version are you using? This
could be a driver issue.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

16 years ago
Simon, Was running an NVidia 32mb TNT2 Card with 52.16 WHQL ForceWare 
(Detonator) Drivers. Rolled back to 45.23 Drivers and all is well. 

Bug Conclusion: Issue with Detonator 52.16 WHQL Detonator Driver.

Whats the situation from here regarding contacting NVIdia about it? 
Reporter

Comment 6

16 years ago
I believe it's already in my original comment.  I am using an nVidia Vantra with
the 52.16 Detonator drivers (official release).

Comment 7

16 years ago
Same issue with my "NVIDIA RIVA TNT2 Model 64".

Installed nVidia's driver version 52.16 and got corruption. Rolled back to
Microsoft's driver version 5.1.2001.0 and everything works fine.

I reproduced this on builds:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031126
Firebird/0.7+
Summary: Icons appear corrupt, overwritten by menu words and lines → Icons appear corrupt with nvidia 52.16 driver

Comment 8

16 years ago
Same issue for me with a NVIDIA RIVA TNT2 Model 64 on Windows XP Pro SP1.

I deleted the install directory and the profiles. I "cleaned" my registry with
Norton WinDoctor to remove any vestiges. And then I downloaded the latest
nightly build. The problem persisted.

The only thing that solved the problem was rolling back the drivers for my video
adapter from 52.16 to the previous version.

Comment 9

16 years ago
Same problem.  win2k sp4. Nvidia Riva TNT2 
Started with the detonator 52.16 driver, same problem
upgraded to the detonator 53.03 driver, same problem
The only solutions I have found, other than backdating the driver, is to use the
Bluemonkey theme, which seems to hide the problem (though hyperlinks still seem
to have an issue) or to back off the hardware acceleration in the display
properties.

Comment 10

16 years ago
I was wondering what was going on. 

Me too, with the tnt2 card, 5216 driver.

If only FB has this problem of all the programs on my computer, is it not an
issue with FB and not Nvidia?

Reassigning
Assignee: hyatt → jdunn
Severity: trivial → minor
Component: Toolbars → Image: GFX
Product: Firebird → Browser
Version: unspecified → Trunk

Comment 12

16 years ago
This is NOT a Mozilla-Firebird-only issue. I have been having the same issue
with Seamonkey (Mozilla Application Suite) for a while. I can't tell the exact
date or nVidia version when the trouble started, but my memory seems to agree
with the timeline everyone else is mentioning -- that is, the problem started
ocurring about version 50 of nVidia's drivers.
I was using Win2000SP4 with Mozilla 1.6a or around that at the time; I have just
reformatted my machine with WinXP SP1. As long as I was using the
Microsoft-provided drivers, everything was fine. As soon as I upgraded to the
latest nVidia driver (to get DirectX 8 support), the problem reappeared.

One other thing... I have noticed that the problem happens in SOME Mozilla
themes but not on others. Pinball is affected; so is Skypilot, and NautiPolis.
But Modern, Classic and GreyModern work fine.

Machine: Athlon 700 MHz, nVidia TNT2 M64. Windows 2000 SP4 and XP SP1. nVidia
drivers 53.03 right now.
*** Bug 232023 has been marked as a duplicate of this bug. ***
Summary: Icons appear corrupt with nvidia 52.16 driver → Icons appear corrupt with nvidia 52.16 driver and later

Comment 14

16 years ago
Posted image Firefox UI

Comment 15

16 years ago
Posted image PNGs messed up
origial site is www.streeck.com/homepage.html

Comment 17

16 years ago
I'd like to confirm this and also
- this caused transparent pngs from the webpage to be corrupted
- this caused images which are marked when selecting text that contains them to
be corrupted.

This happend using
Firefox 0.8 (release) -- UI and webpage
Mozilla 1.6 (release) -- webpage only

Running Win2k SP4 NVidia Driver 53.03 on a ELSA Erazor III Pro (TNT2 Pro ViVo).

My workarround is to take hardware acceleration down a notch, but the Gecko
engine seems to be the only program affected, so I'm not quite sure if this is
the legit resolution.

I've attached three screenshots from Firefox 0.8
*** Bug 234248 has been marked as a duplicate of this bug. ***

Comment 19

16 years ago
In addition to Firefox and Seamonkey, this bug also affects Thunderbird -- which
is probably to be expected.  More detailed descriptions and some more
screenshots available on Bug 234248 (already marked duplicate).

Comment 20

16 years ago
OK, from what info we have gathered here, it seems to be an issue NOT with
Mozilla/Gecko/Seamonkey/Firefox/Thunderbird/*zilla, but a bug with the newer
versions of nVidia's drivers.
Points:
- It only happens with nVidia boards. No complaints from users of ATI, S3, SiS,
Intel, Matrox or whatever other video chipsets are still around and not
hopelessly obsolete.
- It only happens with older, TNT-generation boards (TNT2, Vanta and such).
GeForce and nForce seem to be fine.
- It started happening around version 50 of nVidia's drivers (interestingly,
about the same time they rebranded their drivers from "Detonator" to
"ForceWare". Seems to me there was some major internal changes here).

My guess: they did some kind of optimization here which works fine on GeForce
cards (probably because the relevant function is implemented in hardware on
GeForce cards) but introduced bugs on older cards (where the same function is
implemented in software).

Has anybody contacted nVidia about this?
This seems to be fixed now with the 56.64 driver release from nvidia as reported
by people in bug 184151.

Comment 22

15 years ago
Yes, I have just upgraded to the latest driver (56.72) and the problem seems to
have gone away. Suggest changing status to RESOLVED (maybe with INVALID
resolution, since the problem wasn't with anything Mozilla but with the nVidia
drivers.)
-> WFM
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
Summary: Icons appear corrupt with nvidia 52.16 driver and later → Icons appear corrupt with nvidia 52.16 driver (and later) - works again with 56.64 (and later)
*** Bug 184151 has been marked as a duplicate of this bug. ***

Comment 25

15 years ago
*** Bug 206432 has been marked as a duplicate of this bug. ***

Comment 26

15 years ago
*** Bug 252443 has been marked as a duplicate of this bug. ***

Comment 27

15 years ago
*** Bug 252918 has been marked as a duplicate of this bug. ***
*** Bug 252411 has been marked as a duplicate of this bug. ***

Comment 29

15 years ago
*** Bug 247915 has been marked as a duplicate of this bug. ***
*** Bug 270604 has been marked as a duplicate of this bug. ***
*** Bug 274032 has been marked as a duplicate of this bug. ***

Comment 32

15 years ago
Something that may contribute to peoples continuing to run into this problem is
that Microsoft update still insists on pushing the broken driver.  On my
machines (W2000) that have the new driver, MS Update even labels the broken
driver as being a Critical update!  So you have explicitly refuse the update not
to get it.
Pretty sad.
*** Bug 273482 has been marked as a duplicate of this bug. ***
QA Contact: bugzilla → nobody

Updated

10 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.