Firebird 0.7 doesn't set HTTP_ACCEPT_LANGUAGE

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Dag Oien, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031026 Firebird/0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031026 Firebird/0.7

HTTP_ACCEPT_LANGUAGE is often used for multi-language sites.

This seems to be hard-coded to english only in Firebird (and Camino).

In MacOS X, the list of languages returned in the HTTP_ACCEPT_LANGUAGE should be
taken from what's already set up in the International control panel under MacOS
X system preferences.

Reproducible: Always

Steps to Reproduce:
1. Just check what a CGI-script returns for the HTTP_ACCEPT_LANGUAGE env variable.

Actual Results:  
English only

Expected Results:  
It should output a list of what languages the user understands, and want sites
to return webpages in that language.

This can be taken from the MacOS X language settings (set in the International
system preferences panel).

The list should be weighted so that the preferred language get a higher weight
than the other languages.

There doesn't seem to be a workaround. Which means many sites will only provide
an english version of the site to firebird/camino users on MacOS X.

Comment 1

14 years ago
Just an observation, since I'm not on a Mac to do anything with this bug:

You can manipulate the setting manually in about:config by changing the value
for intl.accept_languages

http://www.vaelen.org/cgi-bin/vaelen/vaelen.cgi?topic=languagemenu-info is an
extension that gives you a UI to make the same changes.

Comment 2

14 years ago
http://www.vaelen.org/cgi-bin/vaelen/vaelen.cgi?topic=languagemenu-info is an
extension which lacks:
1. setting a thing in a menu, which should go to options.
2. cannot set an order of languages (en - fr - es)

what would be nice is a setting of native language, like:
if the servers native language is french i want to get the french, and not the
broken english. but my normal preference is en, then fr.

Comment 3

14 years ago
You can also set these in the Things They Left Out extension.

You can change the language by setting intl.accept_languages appropriately.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.