Closed Bug 224315 Opened 16 years ago Closed 7 years ago

poor grammar in 'is a:' message on unknown content type window

Categories

(Firefox :: File Handling, defect, trivial)

defect
Not set
trivial

Tracking

()

RESOLVED FIXED
Firefox 23

People

(Reporter: rfine, Assigned: AMoz)

References

Details

(Keywords: polish, Whiteboard: [good first bug][mentor=jaws])

Attachments

(1 file, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

The 'What should I do with this?' file that pops up when downloading reports the
type of file with an 'is a:' message. When the type of file starts with a vowel
- e.g. 'Application,' the message reads 'is a: Application,' which is poor grammar.

Reproducible: Always

Steps to Reproduce:




Expected Results:  
The message should probably change the 'a' into an 'an' if the first letter of
the type is a vowel. Failing that, the message should be rephrased entirely to
avoid the problem.
Summary: poor grammar in 'is a:' message on download window → poor grammar in 'is a:' message on unknown content type window
--> NEW, but really low priority :)
Assignee: firefox → bugs
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All
QA Contact: aebrahim
Hardware: PC → All
Or just change the message to "The type of this file is:" which sidesteps having to implement any logic.
QA Contact: ali → download.manager
Assignee: bugs → nobody
Component: Download Manager → File Handling
Product: Firefox → Core
QA Contact: download.manager → file-handling
UI isn't core.
Product: Core → Firefox
QA Contact: file-handling → file.handling
Duplicate of this bug: 437840
This isn't only a Firefox bug. It's in SeaMonkey as well.
Assignee: nobody → amod.narvekar
Status: NEW → ASSIGNED
Attachment #745281 - Flags: feedback?(jaws)
Comment on attachment 745281 [details] [diff] [review]
As per Comment 2, I have kept upto "is:"

Review of attachment 745281 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/locales/en-US/chrome/mozapps/downloads/unknownContentType.dtd
@@ +15,5 @@
>  
>  <!ENTITY  rememberChoice.label        "Do this automatically for files like this from now on.">
>  <!ENTITY  rememberChoice.accesskey    "a">
>  
> +<!ENTITY  whichIsA.label              "which is:">

The entity name here will have to change from whichIsA.label to whichIs.label, so that localizers will know that they should update their string. This means you'll also have to look for references to whichIsA.label throughout the source code. You can use https://mxr.mozilla.org/mozilla-central/ to search through the mozilla-central codebase.
Attachment #745281 - Flags: feedback?(jaws) → feedback+
>  You can use https://mxr.mozilla.org/mozilla-central/ to search through the  
>  mozilla->central codebase.

I had tried earlier using  https://mxr.mozilla.org/mozilla-central/search?string=which+is+a but i almost got fainted to see the results.
 
> The entity name here will have to change from whichIsA.label to whichIs.label
I will upload the patch within a while.
(In reply to Amod [:greatwarrior] from comment #9)
> >  You can use https://mxr.mozilla.org/mozilla-central/ to search through the  
> >  mozilla->central codebase.
> 
> I had tried earlier using 
> https://mxr.mozilla.org/mozilla-central/search?string=which+is+a but i
> almost got fainted to see the results.

You should search for 'whichIsA.label'. Here is the search for your convenience: https://mxr.mozilla.org/mozilla-central/search?string=whichIsA.label&find=&findi=&filter=^[^\0]*%24&hitlimit=&tree=mozilla-central
Attached patch Patchv2 (obsolete) — Splinter Review
I have made the changes.
Attachment #745281 - Attachment is obsolete: true
Attachment #746885 - Flags: review?(jaws)
Comment on attachment 746885 [details] [diff] [review]
Patchv2

Review of attachment 746885 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/mozapps/downloads/content/unknownContentType.xul
@@ +42,5 @@
>        <vbox flex="1">
>          <description id="location" class="plain" crop="start" flex="1"/>
>          <separator class="thin"/>
>          <hbox align="center">
> +          <label value="&whichIs.label;" id="whichIs"/>

I don't see anywhere that this ID attribute is used, and I did a search through XUL-based add-ons and didn't see any references to the ID either. Instead of changing the value of the ID, I think it'd be better if we just dropped it since it isn't serving any benefits.

Once you make this last change the patch should be perfect :)
Attachment #746885 - Flags: review?(jaws) → feedback+
Attached patch Patchv3Splinter Review
with the required changes as said in the previous comment.
Attachment #746885 - Attachment is obsolete: true
Attachment #746950 - Flags: review?(jaws)
Comment on attachment 746950 [details] [diff] [review]
Patchv3

Review of attachment 746950 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me, thanks!
Attachment #746950 - Flags: review?(jaws) → review+
https://hg.mozilla.org/mozilla-central/rev/7003849feda0
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
You need to log in before you can comment on or make changes to this bug.