Closed Bug 224317 Opened 21 years ago Closed 14 years ago

Clean-up band-aid for bug 190611: Query page crashes if any product has no versions defined

Categories

(Bugzilla :: Query/Bug List, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: goobix, Unassigned)

References

()

Details

In bug 190611 we applied a 3-lines band-aid to fix it for 2.17.5. We still need
to figure out why does the patch work the way it does, and to clean it up in a
nice way.

Below is justdave's initial report about the issue:

------------

Can't use an undefined value as an ARRAY reference at
/var/www/html/bugzilla-tip/query.cgi line 250.
[Sat Jan 25 09:39:22 2003] [error] [client 64.236.139.249] Premature end of
script headers: /var/www/html/bugzilla-tip/query.cgi

To reproduce:
1. Go to landfill
2. editproducts
3. pick "Another Product"
4. click on "versions"
5. click "delete" by the only version and confirm it.
6. Go to the query page.

Calling this a regression because we had a couple products with no versions in
them on our test install for some reason, and this didn't crash until this
morning's cvs update.
Reassigning bugs that I'm not actively working on to the default component owner
in order to try to make some sanity out of my personal buglist.  This doesn't
mean the bug isn't being dealt with, just that I'm not the one doing it.  If you
are dealing with this bug, please assign it to yourself.
Assignee: justdave → query-and-buglist
QA Contact: mattyt-bugzilla → default-qa
If this still happens, I'd be surprised. (However, having no versions for any product is not really a supported configuration, also.)
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.