empty subfolder on IMAP server is hidden; awkward to use or delete

RESOLVED WORKSFORME

Status

MailNews Core
Networking: IMAP
--
minor
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: L A Walsh, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       lynx 5.5 (vision impaired version)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030916

on imap account: settings, Server Settings: Advanced:
<checkbox> This server can contain folders that contain folders and messages

This flag seems ignored.

Reproducible: Always

Steps to Reproduce:
1. create folder with subfolders (UofW IMAP only supports folders w/messages 
or subfolders, not both)
2. try marking checkbox mentioned above either way.
3. select folder containing subfolders

Actual Results:  
Get a selection error saying it couldn't open the folder "archive" (which
contains only subfolders that are archives of old mail).

Expected Results:  
If I _don't_ have the checkbox marked, then Mozillamail shouldn't try to
open that folder as a "folder", but should instead as though I had pressed
the "+"  in front of the folder.  Since I've already said the server doesn't
support opening the folder as something that doesn't contain, both,  folders 
and messages, it should only open it as a directory of folders.

If I have the box checked, it would be logical for me to get the error message.
Product: MailNews → Core
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 2

13 years ago
Bug has slightly morphed, same symptoms are not reproducible, BUT
there still seems to be a problem in subfolder usage on an Imap
server.
Steps to reproduce:
1) Create imap account on a linux server;
    (I'm using U-Washington build on SuSE 9.3 version "2004c-3.1")
    (I use subdir 'mail' under /home/username for as the root of my imap 
account)
2) create a sub directory "subdir" in the imap account; "subdir"
   is currently empty, 
   but, you intend to move other mail-folders there or create new ones
   there; Example: have email conv w/a doctor, save in "People" folder under
   doctor's name; now get 2nd & 3rd doctor -- also seperate folders under
   People;  All doctors really work for Kaiser; Kaiser develops online
   service; Start getting some email related to general online-kaiser
   access; considered: create new subfolder for kaiser, and start moving
   old folders and create new folder for general messages.
3a) go into T-bird (currently using version 1.0.6 (20050716)); When I go
   to create folder, I don't find the newly created 'empty' folder
   listed as a possible subfolder option to place it under.
3b) I want to move an existing folder to the subdir; I figured it would
   be easiest to do through TB, as it will handle the folders-subscribed
   list.  But there is no way I can subscribe to an empty directory such
   that it might show up on my folders list.
----
  *workaround that works on in u-wash linux imap server for folder creation:
   where it asks for the folder name, one can type in "subdir/dr_oct" and
   the subdir will be created.  However, if you delete dr_oct and it was
   the last entry in the directory, then you have a "1-time limited offer".
   Before you leave T-bird, you can deleted the greyed out subdirectory
   that will still be listed on your folder list. If you don't do
   something in the current session, the folder is not listed next time
   T-Bird comes up and the empty folder remains on the server.

   *- note, if you have created a subdir/folder then delete the folder,
    you do have the option to create new folder in the "subdir" (but no
    other empty directories).  2nd, if you end your session and bring
    up T-bird again, you no longer see the folder as a selectable
    folder under the "create folder" dialogue.  You do see empty
    subdirectories greyed out on the subscription pane, but cannot
    select them.  

It's all at an annoyance level -- "minor".

Suggested behavior:

I'd show least surprise at being able to checkmark an empty folder as
though it was subscribed to -- but not that it will actually store
messages, but simple enable the name to appear on the folder list
to be used to move folders to.  If you click on the empty subfolder,
it would do the same as clicking on a regular unix-file-system based
IMAP folder, it would display nothing.  The only difference between
it and other folders would be that there was no "+" sign next to
the folder name.  

That design would seem to provide the most UI compatibility and
least user surprise, though I don't know how much engineering
effort it would be worth to fix what I would classify as
a minor annoyance.  There are probably more pressing bugs
to fix, though that doesn't mean folder handling in this
area couldn't be improved or works as one might expect.

I wouldn't be strongly offended if someone wanted to classify
this as an RFE, even though subfolder handling is a bit buggy
in the strict sense of the word.  There are ways (maybe they
only work with UWashington's version of IMAP running on a
*nix compatible OS) of working around the problem, so I
guess I can't tell how serious the problem would be on
another platform if one didn't have login-access to the 
imap server and/or couldn't, "happen to", create folders by
embedding pathname components in the filename.  I'd be
a bit uneasy about expecting the same workaround to work
on a windows port of the IMAP server due to their inane
choice of pathname component seperation being the general
standard for literalizing the next character.  *Doh*...and
whoever even remotely thought Bill Gates had any intelligence
when it came to OS/DOS design....*sigh*...getting _way_ OT.
-l

Summary: folder containg sub folders _only_ shouldn't get 'error' trying to open on select. → empty subfolder on IMAP server is hidden; awkward to use or delete

Comment 3

10 years ago
Still having issue with current version of TB?
(Reporter)

Comment 4

10 years ago
Oh so poopie...wrote a good write up -- testing multiple cases...

Congrats on everything working, better than MS-Outlook in supporting my
50-60 *active* IMAP (IMAPS) folders (sorted into folder via a perl script as the email comes in).  Then I went to look at version of T-bird (2.0.0.12) I was running to include that and hit release notes and help before I got to "about"...and it tried to launch the rel-notes and help topics in the FF browser I  already had open to update this bug -- and it crashed the FF browser!  So lost
paragraphs of description about what was tested, and any possible future confusion points...*ARGH*!!!

Whatever...works fine for me and as I would expect.  AFAIK, TBird is tied or above other clients now in IMAP support (though other clients have been evolving too, I'm  sure), but MS Outlook, I last tried, would hang (require killing app) when looking for new messages in 50-60 active IMAP folders due to it not speaking proper IMAP protocol -- it would deadlock itself waiting for a response from an IMAP server which was waiting for Outlook to finish its previous 'message'.

Congrats and Thanks...(guess FF still has a few 'nits' to work out though...:-) ).

Linda Walsh
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 5

10 years ago
No patch / bug referenced as the code fix.

-> WORKSFORME
Resolution: FIXED → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.