Allow user to turn off Dock feedback (Icon Bounce)

RESOLVED WONTFIX

Status

()

Firefox
Shell Integration
--
enhancement
RESOLVED WONTFIX
14 years ago
5 years ago

People

(Reporter: riscky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a) Gecko/20031028 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a) Gecko/20031028 Firebird/0.7+

Allow the user to turn off Mozilla Firebids desire to bounce when a download
finishes or when a domain doesn't exist.

Reproducible: Always

Steps to Reproduce:
1. Download a file
2. Put Firebird in the backgroud while download proceeds
3. Firebird icon bounces

Actual Results:  
Dock should bounce... (maybe?)

Expected Results:  
Mozilla should let the user turn such feedback off

Many (some) OS X programs in the past have allowed users to turn on and off Dock
bouncing... like chat apps and mail apps...

Comment 1

14 years ago
Just a little comment as Mac Programmer: If an application, which has not focus,
opens a dialog box or changes the content of a dialog box and demands user
confirmation (e.g. it opens a dialog with an OK button you have to click to get
the dialog away), then the icon is supposed to bounce according to Apple's
design guidelines (meaning: Apple says, that's the way how you have to write
software to be Mac conform). Disabling this feature is not desired according to
Apple.

When you develop software and use a plain Cocoa user interface, the icon will
bounce automatically if you open a dialog box for an application without focus
(the programmer isn't even in control of that! He couldn't even prevent that if
he wanted to). Of course in case of Firebird, this is different, as it's doing
all the interface stuff on its own (at least I don't think it relies a lot on
Cocoa or Carbon for rendering other than creating windows and drawable canvas
and so on).

The cases you described, are cases where disabling bouncing would violate
Apple's guidelines:

1. If a domain is not found, a dialog box opens that demands user confirmation,
right? That means if the app isn't active, it's supposed to bounce.

2. If a download finishes, the content of a dialog box changes (the download
dialog box) and it won't go away automatically (unless you chose that), right?
In that case the icon is supposed to bounce as well.

The cases you were talking about, like mail and chat clients, are cases, where
the bouncing is started manually by the programmer (you can call a method to
make the icon bounce, even if there is no dialog in sight). E.g. when a mail or
chat message arrives, this doesn't lead to the creation or change of any dialog,
does it? So here the programmer just offers you the option to decide if the icon
should bounce or not in that case... something Apple's design guidelines don't
cover at all.

Comment 2

14 years ago
Bug 182784 (for Camino) quotes the HIG as saying you *should* have a pref to
turn off bouncing.

Comment 3

14 years ago
Reasonable enhancement request, duplicate search shows no Firefox dupes.
Confirming and triaging component.
Status: UNCONFIRMED → NEW
Component: General → Shell Integration
Ever confirmed: true
QA Contact: os.integration
Assignee: bross2 → nobody
This isn't something that we should consider adding a preference for. Disabling this feature, and then forgetting that the feature got disabled, will only create a poor user experience.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.