If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Drop down nav menus appear in different place than in the Windows version of Firebird 0.7 & Clicking on them does nothing

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Aaron Campbell, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv1.5)

The drop down menus at the top of the page work fine in my windows version of 
Firebir 0.7, but on my linux machine, using the same browser, they don't work.  
They appear in the wrong places, and even when you get the mouse over them to 
click (you CAN do this if you play with it enough), they do nothing.

Reproducible: Always

Steps to Reproduce:
1. Try using the nav-bar @ http://campbells.dikaios.net in the Mozilla Firebird 
0.7 Windows Version
2. Try using the nav-bar @ http://campbells.dikaios.net in the Mozilla Firebird 
0.7 Linux Version

Actual Results:  
Menus were non-functional, even though the code is COMPLETELY w3 standard

Expected Results:  
Exactly what was seen in the windows version.

Code on site is w3 standards compliant

Comment 1

14 years ago
Confirming unable to click submenus - they disappear before they can be reached
with the mouse pointer.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031028 Firebird/0.7+.

Comment 2

14 years ago
WFM, Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040407 Firefox/0.8
(Reporter)

Comment 3

14 years ago
Ok, I have found that this seems to have been a bug in the web-site, not in 
this program.  Usually, it's because when you calculate a position using js, 
you forget to add the 'px' to the end of the string.  Here is some code that 
works:

var position = getElementPosition(parent);
menu.style.left = position.left-menu.offsetWidth+'px';
menu.style.top = position.top-menu.offsetHeight+'px';


function getElementPosition(elemID) {
    var offsetTrail = document.getElementById(elemID);
    var offsetLeft = 0;
    var offsetTop = 0;
    while (offsetTrail) {
        offsetLeft += offsetTrail.offsetLeft;
        offsetTop += offsetTrail.offsetTop;
        offsetTrail = offsetTrail.offsetParent;
    }
    if (navigator.userAgent.indexOf("Mac") != -1 && 
        typeof document.body.leftMargin != "undefined") {
        offsetLeft += document.body.leftMargin;
        offsetTop += document.body.topMargin;
    }
    return {left:offsetLeft, top:offsetTop};
}

Ok, I'm kinda in a hurry, so if any of this is missing stuff, or doesn't make 
any sense, E-Mail me at bug224438@autotransportteam.com">bug224438@autotransportteam.com

Comment 4

14 years ago
not a mozilla bug then
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.