Favicons not shown in location bar after disabling 'browser.chrome.site_icons' (changing this pref seems to have no effect)

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
RESOLVED INVALID
15 years ago
12 years ago

People

(Reporter: Tobias Schacht, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031102 Firebird/0.7+ (Gcc 3.3.1 i686 optimized - MozJF)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031102 Firebird/0.7+ (Gcc 3.3.1 i686 optimized - MozJF)

Disabling 'browser.chrome.site_icons' (set to 'false'), which should only
disable favicons in bookmarks, also disables favicons in the location bar.

Reproducible: Always

Steps to Reproduce:
1. set 'browser.chrome.favicons' to 'true' (favicons in location bar should be
enabled)
2. set 'browser.chrome.site_icons' to 'false' (favicons in bookmarks should be
disabled)

Actual Results:  
Favicons are not shown in the location bar.

Expected Results:  
Favicons shuld be diabled in bookmarks, but shown in location bar.

I'm using Preferential 0.5.3 extension and don't know if the description of the
pref (and so my expectation) is correct. However 'browser.chrome.site_icons'
seems to have no effect.
-> bookmarks

pch, I took a brief look at lxr, what exactly should each pref do?
Assignee: blake → p_ch
Component: General → Bookmarks
QA Contact: mpconnor
(Reporter)

Comment 2

15 years ago
If the descripton in Preferential 0.5.3a ( http://preferential.mozdev.org/ ) is
right:

browser.chrome.favicons -> enable/disable favicons in location bar
browser.chrome.site_icons -> enable/disable favicons in bookmarks

Comment 3

15 years ago
Here's how I think these two preferences work.  There are two ways of getting an
icon to appear in the URLbar.

First, you can place a favicon.ico file at the root of the web site.  This
feature requires both preferences to be true.  This type of icon may (or may
not, depending on the file itself!) appear next to bookmarks.  There are many
examples of this type of web page.  Try news.bbc.co.uk for one that appears in
bookmarks, or www.jobserve.com for one that doesn't.

Or, you can add an HTML LINK tag explicitly specifying an image file (only ico
or png, I think).  www.mozilla.org is one of the few examples of this.  Note
that the LINK tag in particular has a number of problems and is likely to
disappear and reappear at various times.  I think this is related to whether
firebird looks in the cache or not.

Hope I got that all right.  Whether this is the intended or desired behaviour I
don't know.

Comment 4

14 years ago
this is not a bug.  this is as expected.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.