DNS: resolving host takes much longer that it should

VERIFIED WORKSFORME

Status

()

Core
Networking
VERIFIED WORKSFORME
14 years ago
14 years ago

People

(Reporter: John Griffiths, Assigned: Darin Fisher)

Tracking

({perf})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031031
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031031

When opening mozilla for the first time, resolving the first host takes a long
time. A ping or nslookup of the same host returns immediately.

Reproducible: Always

Steps to Reproduce:
1. Open mozilla browser
2.
3.

Actual Results:  
Status message appears "resolving host ...." and mozilla sits there. After a
while, probably a timeout period, the host is resolved and the web page opens.

While mozilla is still resolving, a ping of the host returns immediately with
ping times.

Expected Results:  
Mozilla should have resolved the host. If ping can resolve the host almost
immediately, mozilla should be able to.

Using Multizilla and Skypilot theme.
(Reporter)

Comment 1

14 years ago
Disabled Multizilla and changed to Classic theme and problem still exists.

Updated

14 years ago
Keywords: perf
Summary: Resolvng host takes much longer that it should → DNS resolving host takes much longer that it should

Comment 2

14 years ago
Was this fixed by bug 223811 (in the latest trunk build) ? I'm not seeing an
AAAA-record for www.foxnews.com though ...
(Reporter)

Comment 3

14 years ago
> www.foxnews.com
Server:  gei.grifent.com
Address:  192.168.1.2

Non-authoritative answer:
Name:    a20.g.akamai.net
Addresses:  209.51.177.25, 209.51.177.33
Aliases:  www.foxnews.com, www.foxnews.com.edgesuite.net

>

Could the problem be that the site resolves to more than one IP?

I have tried a couple of sites for startup sites that resolve to only one IP and
they resolve and open quickly. I have not searched for sites that resolve to
multiple IPs to test the oposite case.
(Assignee)

Comment 4

14 years ago
WORKSFORME.  what version of linux are you using?  and what version of glibc do
you have installed?  (you can type: "ls -l /lib/libc.so*" to find out.)
(Reporter)

Comment 5

14 years ago
/lib/libc.so.6 -> libc-2.2.4.so

Seems to work ok with this build 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031103 MultiZilla/1.5.0.3l

Comment 6

14 years ago
John: can we mark this "works for me"?
Summary: DNS resolving host takes much longer that it should → DNS: resolving host takes much longer that it should
(Reporter)

Comment 7

14 years ago
Yes
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 8

14 years ago
V per reporter.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.