Links with internal span do not work

VERIFIED DUPLICATE of bug 21186

Status

SeaMonkey
General
P3
major
VERIFIED DUPLICATE of bug 21186
18 years ago
13 years ago

People

(Reporter: bertilow, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Links which include a span-element stop being links.

An example can be found at the URL above: The first line
of that page consists of four links, but they all appear as
ordinary text in M12 (and earlier builds).

The HTML is like this:

  <a href="enhavo.htm" accesskey="e"><span class="klavo">E</span>nhavo</a>

The span-element is there to high-light the letter that is used as
accesskey. If I change span to e.g. em, the link will work.

(The acceskey attribute is not the cause of the problem.)

Comment 1

18 years ago
Not only is this a duplicate of bug 21186, but it has been fixed in 1999122208.

I'll let someone else make the necessary changes.

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Yes, this is a dup of bug #21186, and it is fixed in the current code.
Thanks for the bug report.

*** This bug has been marked as a duplicate of 21186 ***

Comment 3

18 years ago
verified duplicate of 21186 - span inside anchor bug
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.