Closed Bug 224586 Opened 16 years ago Closed 16 years ago

'Save page as' does not save CSS linked with @import

Categories

(SeaMonkey :: General, defect)

All
Linux
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 126309

People

(Reporter: chris, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030927
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030927

When the 'Save page as' and 'Web page complete' are used then any CSS that is
linked using @import appears not to be saved.

For example this page:

  http://www.indymedia.org.uk/

Links to the CSS like this:

  <style 
    type="text/css" 
    media="screen" 
    title="UK Style"
  >@import url(/style/uk.css);</style>

In order to prevent NN4 and IE4 from getting the CSS (the layout stuff makes a
real mess of older browsers...)

With the web page complete version this address is not rewritten in the way that
it is with CSS linked using link rels.

Reproducible: Always

Steps to Reproduce:
1. Find a page that uses @import for linking to the CSS
2. Save the page as a web page complete
3. Open the saved page
4. Observe that there is no CSS styling

Actual Results:  
A page without CSS

Expected Results:  
Re-written the URI of the CSS and downloaded the CSS and rewritten all the links
to images etc in the CSS andalso downloaded those.
This should probably be linked to from this tracking bug?

http://bugzilla.mozilla.org/show_bug.cgi?id=115634
Summary: 'Save page as' does not save CSS linked with @import → 'Save page as' does not save CSS linked with @import

*** This bug has been marked as a duplicate of 126309 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.