My profiles gets deleted if computer crashes and i think i have mozilla running when ever this happens

RESOLVED DUPLICATE of bug 205120

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 205120
14 years ago
7 years ago

People

(Reporter: manne muoniovaara, Unassigned)

Tracking

({dataloss})

Trunk
x86
Windows XP
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030916
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030916

I've lost now three profiles. It's kind of furustrating to notice after boot
that everything is gone. Mails, settings, links etc. Now howcome it's possible
to operate profiles whole time rewrite or accessed so that if computer crashes
the data is gone?. I'm a little bit angry with this because these mails etc. are
very IMPORTANT. You really should concentrate on stability eventhough machine
crashes because it's a fact that computers crashes all the time. Now i'm not a
coding genious but i certainly know when data is lost and how does it happen.
I.ex. all the data is read to memory and computer crashes does it happen when
you have files open? Other programs have never lost a file/files and never been
damaged of crashing. Im very angry atm so please get in contact. Is there any
way to get that lost profile back.

Reproducible: Didn't try

Steps to Reproduce:
1. Start mozilla
2. Do something stupid (try to write data to certain memoryareas that are
already open)
3. Check after reboot if your profile is still there

Actual Results:  
haven't tested

Expected Results:  
LEAVE THE FILES ALONE PERHAPS? Just write when you have to, make backup of
profile after about 2days or maybe after a period defined by user.
(Reporter)

Comment 1

14 years ago
Latest additions:
I found out that all my favorites, mails and settings are still there. Now i
dont'  t have a clue why those doens't show up in mozilla. I tried to delete
profile and create another with same name and same location then overwrite files
with my old profile but it doesn't work. Which files do i have to edit to get
those settings to work? Need answer asap there are very important data which i
would like to recover. Data is now packed in some .dat format and i simply don't
know how to open it. 

Updated

14 years ago
Keywords: dataloss

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 193749 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You can try http://matti.no-ip.org/mozilla/profile.txt

not a dupe of that bug
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
loosing the mail settings indicates a lost prefs.js, loosing the favorites while
they are still there is a lost registry.dat.

Loosing the registry.dat is a dupe of bug 205120

*** This bug has been marked as a duplicate of 205120 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Blocks: 193638
You need to log in before you can comment on or make changes to this bug.