Page-up key trips and falls down

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Paul Rogers, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

I was browsing a page on Amazon.UK, for the "Da Vinci Code" if you must know,
and being rather far down the page, pressed the page-up key.  This worked as
expected several times, but mid-way wouldn't go up anymore, but sent me a couple
pages down!  (Something in the page's HTML or Java?)  I used the mouse on the
scroll bar, and that went to the top.

Reproducible: Didn't try

Steps to Reproduce:
1.Go to the Amazon page bottom, and try pressing page-up.
2.
3.

Actual Results:  
At a certain point in the page it began sending me down.

Expected Results:  
up up up
Works for me

I'm assuming that the page is http://www.amazon.co.uk/ and not amazon.uk

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031102 Firebird/0.7+
Works for me

I'm assuming that the page is http://www.amazon.co.uk/ and not amazon.uk

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031102 Firebird/0.7+
(Reporter)

Comment 3

15 years ago
I reproduced the effect again on that page.  It didn't happen with the "Move
system caret with focus/selection changes" unchecked.  But when it was checked,
I guess depending on exactly what content was on the page, and where the cursor
was, it did go down when I pressed page-up.

I suppose being content dependent it might be working "properly", I'm not expert
enough to tell.  And I'm not quite sure why one would want to use that option--I
was just experimenting to see what it was about and I'm still not sure.  But
from the user's perspective, it certainly is counter-intuitive.
Its an accessibility feature, if there was a form element like a textbox it
would probably end up there, depending on the scroll.  It makes sense for
certain user types, and this is not a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.