Remove obsolete files from extensions/spellcheck

RESOLVED DUPLICATE of bug 339106

Status

()

Core
Spelling checker
--
minor
RESOLVED DUPLICATE of bug 339106
14 years ago
7 years ago

People

(Reporter: Michiel van Leeuwen (email: mvl+moz@), Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

There are a few unused files in extensions/spellcheck/src:

nsSpellCheckController.cpp
nsSpellCheckController.h
nsSpellCheckModule.cpp
nsSpellCheckModule.h
nsSpellCheckUtils.cpp
nsSpellCheckUtils.h

They should be removed, to reduce confusion. They became unused when the
spellchecker went in to the default builds.
(Reporter)

Comment 1

14 years ago
Created attachment 134924 [details] [diff] [review]
patch to remove the  files

Comment 2

14 years ago
Are we sure that rods will never finish this work?

Comment 3

14 years ago
if he ever wants to, he need but look in bonsai :)

Updated

14 years ago
Component: Editor: Core → Spelling checker
QA Contact: bugzilla → core.spelling-checker
(Reporter)

Updated

13 years ago
Attachment #134924 - Flags: superreview?(mscott)
Attachment #134924 - Flags: review?(timeless)

Comment 4

13 years ago
Comment on attachment 134924 [details] [diff] [review]
patch to remove the  files

what about:

http://lxr.mozilla.org/mozilla/source/extensions/spellcheck/src/nsSpellCheckMod
ule.cpp#48

which references spellcheckccontroller?
(Reporter)

Comment 5

13 years ago
The patch removes that file too. (check comment 0 for an easier to read list)

Comment 6

13 years ago
Comment on attachment 134924 [details] [diff] [review]
patch to remove the  files

ah right you are.
Attachment #134924 - Flags: superreview?(mscott) → superreview+

Updated

12 years ago
Attachment #134924 - Flags: review?(timeless) → review+
(Reporter)

Comment 7

11 years ago
I don't have time to work on this. I don't even know the current status of the files...
-> default owner
Assignee: mvl → mscott

Updated

9 years ago
Assignee: mscott → nobody
The files in comment 0 no longer exist, since they were removed as part of bug 339106. Marking as dupe of that.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 339106
You need to log in before you can comment on or make changes to this bug.