Unable to enter data (e.g. username & password) from keyboard

RESOLVED EXPIRED

Status

SeaMonkey
Passwords & Permissions
--
major
RESOLVED EXPIRED
14 years ago
12 years ago

People

(Reporter: Earl Eiland, Assigned: dveditz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

I'm able to log in via the "auto logon" feature, but not manually.  when I click
on a data  entry box, the blinking cursor doesn't appear, nor do keystrokes. 
This is consistent acrossthe website  I'm not able to enter data on other pages
once logged on.

Capital One Customer Support and Tech Support calin this is a browser issue.

Reproducible: Always

Steps to Reproduce:
1.go to site.
2.click on log in button
3.click on data entry box

Actual Results:  
Nothing happens.

Expected Results:  
Expected blinking cursor to appear and keystrokes to appear in box.

Comment 1

14 years ago
WFM 20031101 PC/WinXP
Worksforme, linux trunk build 2003-11-03-05 as well....

Comment 3

14 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4.1) Gecko/20031008
https://service.capitalone.com/oas/login.do?objectclicked=LoginSplash
can set cursor, can input username and password, didnĀ“t submit.
(Reporter)

Comment 4

14 years ago
It appears that my problem may not be with either Mozilla or the website.  Any
idea what else could be causing a failure to accept keyboard input?  I don't
have this problem with any site except capitalone.com.

The problem first occurred while using Mozilla 1.2.  My first attempt at a fix
was to upgrade to 1.4.

I'm running RH9 original kernel(2.4-8.20?), GNOME 1.2, with all of the RH
released patched installed.
(Reporter)

Comment 5

14 years ago
I checked to see if the problem exists when using a new profile.  It doesn't, so
apparently it's related to the profile somehow.
Are there any errors in the JS console when you see the bug?  Clear the console,
then load the site and try to type in the textfields.

If there are no errors, please attach you prefs.js file to this bug.
(Reporter)

Comment 7

14 years ago
I've got to install JS Console before I can do this.  Unfortunately, when
installing, I get the message :"unexpected error-2", so I'm waiting on mozdev to
take care of that...
JS console is there by default in Mozilla builds... it does not need to be
installed.
(Reporter)

Comment 9

14 years ago
" I see" said the blind man!  
mozilla help didn't have anything on the JS console, so I went to mozdev. 
Instructions there specified looking for JS console in the Windows drop down
menu.  Since it wasn't there, I assumed I needed to install it.

Knowing it was already installed, I poked around until I found it in the
Tools>WebDevelopment menu.

When I go to the capitalone.com login page, I get the following error message on
the JS Console 
Warning: The stylesheet
http://www.capitalone.com/stylesheets/https-common/stylesheet.css was loaded as
CSS even though its MIME type, "application/x-pointplus", is not "text/css".

Looks like we've gotten to the root of the problem.
No, that's just a warning, not an error... we're still loading and applying that
stylesheet.  If it were an error, it would say it wasn't loaded. ;)
(Reporter)

Comment 11

14 years ago
Any more tests I should run?  To summarise results so far:

Data entry works when using a new profile
JS console reports  warnings, but no errors.
Does data entry work if you copy the prefs.js from your old profile to the new
profile (and then test the new profile)?
(Reporter)

Comment 13

14 years ago
Yep. It works just fine.
hmm.. keep moving various files over one by one and see at what point it breaks?
(Reporter)

Comment 15

14 years ago
CORRECTION:

The problem only occurs when I have two login/password choices.  Once logged in
(via the "auto login" feature), the problem persists on other pages.

Switching files between profiles with no login choices on the new profile had no
effect - data entry worked fine.
OK.  what if you create a new profile and set up two login choices?  Does the
problem manifest immediately then?
(Reporter)

Comment 17

14 years ago
Yep.
Hm.... out of curiousity, what windowmanager are you using?  Is this a problem
with all windowmanagers?
(Reporter)

Comment 19

14 years ago
gnome (1.2?).  whatever version comes with RH9.

I haven't tried any others.  I have KDE installed, but don't know how to switch 
That's a desktop environment, not a window manager... The window manager is the
program that actually lets you move and resize your windows and such.

Check whether any of the root menus (the ones you can get by clicking or
right-clickin on your desktop) have an option to launch something called twm or
fvwm or such?

In any case, it sounds like there is a focus issue when we're supposed to be
bringing up a dialog.  I assume the "select user" dialog does not appear?
(Reporter)

Comment 21

14 years ago
right clicking on the desktop doesn't bring up any options like that.  The
closest  is 'new window", which opens a graphical directory of /home/earl/ when
clicked.

Closing mozilla and restarting it brings the "select user" dialog box up.
(Reporter)

Comment 22

14 years ago
I haen't been able to figure out how to switch window managers, but tested
Mozilla in KDE and RH9's failsafe desktops.  KDE may use the same wm, but the
failsafe definitely used something different.  The problem shows up in all three.
Are you sure it used a different wm?  Or just a different skin for the same wm?

The simple way to switch WMs is to kill your current WM and then start another
one.  Eg make sure you have 'twm' installed, in GNOME kill 'metacity' and start
'twm'.
(Reporter)

Comment 24

14 years ago
I believe I ran windowmaker, fvwm95 and fvwmMWM.  The problem existed in all
three trials.
(Reporter)

Comment 25

14 years ago
Just for comparison, I installed and tried logging on to capitalone.com with 
Opera.  I had no problems.  So far, every test I've run seems to indicate this
is an issue specific to Mozilla.

As far as I can tell, this is a confirmed bug.  Unfortunately, I have no idea
whom to reassign it to.
Over to form manager, since that's what triggers it.
Assignee: general → dveditz+bmo
Component: Browser-General → Form Manager
(Reporter)

Comment 27

14 years ago
What can I be doing here to expedite correcting this issue?
I'm not sure, exactly...  Neil?  Any ideas what's up here?

Comment 29

14 years ago
Can you clarify the problem?

You say that the problem only occurs when you have two passwords saved.
Have you tried this with other sites, e.g. Bugzilla?
(You don't have to create a new account, iirc logging out and logging in with a
fake username and password should prompt password manager to save it).

Do you open the url in the current window, a new tab, or a new window?

If you press Ctrl+L or Alt+D does the cursor appear in the location bar?
Component: Form Manager → Password Manager
(Reporter)

Comment 30

14 years ago
I have no trouble on bugzilla.  I can cancel the auto login, and the cursor
starts blinking in the text entry bos as expected.

I usually open the url in the current window.  Opening a new window via the drop
down menu, and then clicking on the bookmark results in the same problem.

Cntrl-L and Alt-d have no effect.

I just discovered, however, that switching windows (any window, not just between
Mozilla windows, even an empty desktop) makes the cursor appear.

Another problem that also occurrs occasionally, also unique to capitalone.com,
is that when I click on the login button on the home page, I frequently get two
advisory windows popping up:
 "you have requested an encrypted page..." clicking on OK brings up the window
"you are leaving an encrypetd page ..."  clicking OK then takes me back to the
home page.

While testing what makes the missing cursor appear, the above sequence happens
every time I have the cursor on the login page, go back to the home page and
then click on the login button.  Clicking on the login button a second time
takes me to the login page, sans the cursor.

Comment 31

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107
Firefox/1.0 downloaded November 10, 2004.

platform is Toshiba Satellite A65-S126 running Windows XP home version with
latest updates.

mouse is viewsonic wireless optical MW 206 dated March 2004

LAN is Netgear wireless

Adapter is Integrated Wi-Fi 802.11b/g

First time user of Firefox.

Created new user profile and replicated problem.

Problem is on tdwaterhouse.com homepage;  cannot enter any characters in the
username or password boxes on this homepage.

Tried same thing on buyandhold.com and everything works perfectly all the way in
to opening the account and navigating.
Product: Browser → Seamonkey

Comment 32

13 years ago
current policy is to not include this ability.  see bug 63961

resolving WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX

Comment 33

13 years ago
oops.  wrong bug

Earl: have you seen this recently (with 1.7 or 1.8b1)?  Many focus problems have
been fixed since 1.4
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.