Crash on starting with an invalid page fault in module GKLAYOUT.DLL

RESOLVED WORKSFORME

Status

()

Core
Layout
--
critical
RESOLVED WORKSFORME
15 years ago
12 years ago

People

(Reporter: Nigel Pauli, Unassigned)

Tracking

({crash, stackwanted})

Trunk
x86
Windows 98
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3.1) Gecko/20030425
Build Identifier: ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.6a/mozilla-win32-1.6a-installer.exe

This bug was originally reported as comment #7 to bug 208146 but I now believe
it is a bug in its own right and not a duplicate of that.
Mozilla installed correctly but on attempting to start it up it crashed with
this message.

-----start copy----
MOZILLA caused an invalid page fault in
module GKLAYOUT.DLL at 015f:0119e44e.
Registers:
EAX=00000000 CS=015f EIP=0119e44e EFLGS=00010246
EBX=00000000 SS=0167 ESP=0066f458 EBP=0066f50c
ECX=007b70bc DS=0167 ESI=007b6940 FS=308f
EDX=00000000 ES=0167 EDI=007bf800 GS=0000
Bytes at CS:EIP:
8b 08 50 ff 51 0c 8b 46 48 39 58 3c 0f 84 c9 00 
Stack dump:
007b70bc 006e4a6c 006e4a6c 00000000 0066f5fc 00000000 0066f60c 0066f686 00000000
0066f686 0066f5fc 007be740 007be7ba 00000000 007be7ba 007bf80c
----end copy----



Reproducible: Always

Steps to Reproduce:
1.Install Mozilla 1.6a
2.Attempt to run Mozilla
3.

Actual Results:  
Mozilla crashed with error message given above

Expected Results:  
Run for the first time after install.
Please use a talkback build and post the talkback incident ID in this bug.

Updated

15 years ago
Keywords: crash

Comment 2

15 years ago
Over to Layout.
Assignee: general → other
Component: Browser-General → Layout
QA Contact: general → ian

Comment 3

15 years ago
Boris, there is no talkback packaged with 1.6a windows, not in the zip build,
nor the full installer, nor the windows XPI, 947 bytes is a dummy.
The Linux XPI holds 805 kbytes.
Latest windows nightly is from 2003-10-28, including 254 kb talkback, the real
thing.
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/2003-10-28-04-trunk/

Nigel, from your initial comment:
Graphics card is, unfortunately, ATi RageIIC AGP 4Mb RAM 

All I know is there can be problems with some ATI-cards,
do you know the version of your driver, is it the latest?

You are reporting with Mozilla 1.3.1, so I assume it was working, and now you
wanted to upgrade to a current release.
Did you try other mozillas, newer than 1.3.1, with bad results?
Did you install into a new directory, and create a new profile?
Perhaps you should try this, just for test, maybe there are some old extensions
in your profile, maybe Spellchecker, or TBE?
Did you read the links in bug 208146 comment 4 ?
I don´t know about ATI problems, I had my problems with a SiS6326 on linux, not
mozilla.


And one nit:
if you write reported as comment #7 to bug 208146, that´s good style, but
bugzilla is dumb, refers to comment #7 in this bug.
It likes the wording bug 208146 comment #7 more, and makes the link to your
comment in bug 208146.
(Reporter)

Comment 4

15 years ago
Hermann,
Before installing Mozilla 1.6a I deleted previous install directory and profile.
I had first attempted to install Mozilla 1.4.1 as replacement to Mozilla 1.3.1
but mozilla failed to launch with no error message given (see bug 224410). So
I've now reverted to 1.3.1.

Comment 5

14 years ago
I have the same problem with 3 of 12 Win95b computers. 
( Win95b, Office97, Waterfall, 3Com 3c509, S3 graphic adapter)
Computer 1 & 2:
v1.3.1 is working, 1.4 & 1.5 crashes at startup, 1.6a crashes with page fault in
GKLAYOUT.DLL.
Computer 3 is a clean W95b installation without previous versions of Mozilla.
Mozilla crashes with v1.5 without error message and with v1.6 with: 
-------------------
MOZILLA verursachte einen Fehler durch eine ungültige Seite
in Modul GKLAYOUT.DLL bei 0137:01a4e44e.
Register:
EAX=00000000 CS=0137 EIP=01a4e44e EFLGS=00010246
EBX=00000000 SS=013f ESP=0066efa4 EBP=0066f058
ECX=0081ef8c DS=013f ESI=0081efa0 FS=0db7
EDX=00000000 ES=013f EDI=0081ee00 GS=0000
Bytes bei CS:EIP:
8b 08 50 ff 51 0c 8b 46 48 39 58 3c 0f 84 c9 00 
Stapelwerte:
0081ef8c 007790c4 007790c4 00000000 0066f148 00000000 0066f158 0066f1d2 00000000
0066f1d2 0066f148 0081d510 0081d58a 00000000 0081d58a 0081ee0c 
-------------------------

v1.3.1. is working properly on all computers.

Comment 6

14 years ago
addition: 
i use trio64, s764, matrox trio64+ graphic adapters but there is no coherence
between graphic adapter & crashes. 

Comment 7

14 years ago
Similar crash in Mozilla v. 1.6b when trying to click on a bookmark in the
Manage Bookmarks window:

MOZILLA caused an invalid page fault in
module GKLAYOUT.DLL at 016f:01a42ad3.
Registers:
EAX=00000001 CS=016f EIP=01a42ad3 EFLGS=00010246
EBX=025990c0 SS=0177 ESP=0066e554 EBP=0066e6d4
ECX=01ae58b0 DS=0177 ESI=00000000 FS=4467
EDX=025990c0 ES=0177 EDI=0066e8ec GS=0000
Bytes at CS:EIP:
89 30 8b 7b 34 8b 43 48 3b fe 89 45 e0 89 7d f8 
Stack dump:
0066e8ec 0066e794 0066e811 007bc5b0 01b73876 0066e8ec 030ca2c4 01b798b0 0028b5bc
bff728a2 44481385 480ab1da 01772690 1016b598 0066e7fc 0066e664 

Comment 8

14 years ago
does it still happen with 1.7rc3 ?
Keywords: stackwanted

Comment 9

14 years ago
I am now seeing this (or very similar) after installing recent 1.8 builds
(probably last 3 weeks worth). Submitted talkback ID TB825063G

Comment 10

14 years ago
The crashing in my case was caused by the installation of AdBlock
http://www.mozdev.org/projects/active.html (to fix the crahs I had to remove its
jar file from the chrome/ dir and delete chrome.rdf). 

Can the severity of this bug be elevated to Blocker since it (seems to be new);
older versions didnt crash with that plugin (rhough I realize it could just be a
compatibility issue), or at least for the fact tht incompats arent handled
gracefully?

Regular users who experience this (uncaught error) will find their profiles
completely unsuable and wont have clue as to how to remove an incompatible
plugin.... I for one rely on Moz for my work email.

On a related-thought, this seems to be related to the installer's "3rd oparty
plugins will be deleted", which only deletes extensions in the main directory
and not user plugins (as in my case)...
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 12

12 years ago
Since this bug hasn't been posted to in ages, and it only seemed to affect platforms that are no longer supported by mozilla, I'm resolving it worksforme. If it's still a problem, please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.