google search only works with ascii-text

RESOLVED FIXED

Status

Camino Graveyard
Toolbars & Menus
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: Daniel Elmiger, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a) Gecko/20031103 Camino/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a) Gecko/20031103 Camino/0.7+

The google toolbar search works fine, but it doesn'r recognize
non-ascii-characters (try the word "exposé", with an accent on the final e).
accents as well as other diacritics work well within google, but not from the
google search within camino.
thanks for fixing that, I've been using chimera/camino for a long time now. It's
terrific!

Reproducible: Always

Steps to Reproduce:
1. type any word with a diacritics in the google search field (toolbar).
examples: "exposé", "señor", "Mädchen"
2. watch the results in the google page.
3.

Actual Results:  
Non-ascii letters are not recognized. The google search thus gets corrupted.
Instead of "señor", google searches for "señor"

Expected Results:  
Transmit the exact caracters to google. (not only the small ascii-set)

I work on panther (10.3); but I think this bug has been there ever since the
appearance of the google searchbar.
(Assignee)

Comment 1

14 years ago
fixed last night. you're one day late :) try today's nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 2

14 years ago
Mike, I do have the problem with 2003111414, apparently the latest nightly
build. The URL bar reads http://www.google.com/search?q=exposé and then it
switches to UTF-8 and Google actually performs the search on the UTF-8 text.

Maybe I need to delete some preference file?

Paul
You need to log in before you can comment on or make changes to this bug.