[PP] URL text field not updated by Back/Forward arrows, links, Link walker, etc.

VERIFIED FIXED in M2

Status

Core Graveyard
Viewer App
P2
normal
VERIFIED FIXED
19 years ago
9 years ago

People

(Reporter: Eli Goldberg, Assigned: Steve Dagley)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
* TITLE/SUMMARY
[PP] URL text field not updated by Back/Forward arrows, Link walker, etc.

* STEPS TO REPRODUCE
0) Launch Viewer
1) Enter a URL (I used "www.machack.com")
2) Enter a second URL (I used "www.macintouch.com")
3) Press the "Back" button
4) Press the "Forward" button

* RESULT
 - What happened

After step #3, the URL field isn't updated; it only shows the URL that was
explicitly typed into it.

Ditto after step #4.

 - What was expected

URL field to be updated upon page changes.

* REGRESSION

 - Occurs On
        viewer (1.7.98 build for Mac OS)
        viewerDebug (1.4.98 build for Mac OS)

 - Doesn't Occur On
        viewer (1.7.98 build for Win32)

[will check Linux and append.]

* CONFIGURATIONS TESTED

- PowerMac 8500/150 (233 Mhz 604e), 64 MB RAM, Mac OS 8.5.1
(Reporter)

Updated

19 years ago
Summary: [PP] URL text field not updated by Back/Forward arrows, Link walker, etc. → [PP] URL text field not updated by Back/Forward arrows, links, Link walker, etc.
(Reporter)

Comment 1

19 years ago
By the way, the content does appear to be somehow updated, just not visually.
Here's an example of what I mean:

1. Go to www.yahoo.com
2. Click on the "What's New" link at the top
3. In the URL field, select the text "yahoo" as part of the domain name, and type
in "netscape"

---> As soon as you type a character into the URL field, the actual URL (rather
than the one that we typed in earlier) will appear in the URL field. You can also
get the same results in some pages by resizing the window. <--
(Reporter)

Comment 2

19 years ago
** Note that this bug doesn't occur on Linux, either; just Mac OS. Yum. (tm)
(Reporter)

Comment 3

19 years ago
*** Bug 2290 has been marked as a duplicate of this bug. ***
Digging with the debugger, the new text is being correctly set, just the widget
isn't redrawn after the text changes. Windowshading the window will force a
redraw that causes it to display correctly. Viewer is doing the right thing, but
the redraw just isn't happening.
fix in hand, waiting for tree to open.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
added a call to invalidate the widget on SetText()
(Reporter)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 7

19 years ago
Re-opening after checking 1.13.99 Mac builds.

Specifically:

- launched 1.13.99 build
- selected contents of URL field
- replaced with 'www.macintouch.com'
- hit return
- Pressed the "Back" button.

Now, the URL text field was simply left blank, including after resizing the
window. Ditto after going forward. Same behavior upon clicking on a web page's
link.

Good luck. ;)

Updated

19 years ago
Resolution: FIXED → ---

Comment 8

19 years ago
Clearing Fixed resolution.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
This should really be fixed now.
(Reporter)

Comment 10

19 years ago
<Will check today's builds...>
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

19 years ago
Verified fixed in 1.14.99 build. (Haven't specifically done a full set of
verifications; just haven't seen any problems after a few hours of regular use.)

Thanks, Mike!

Comment 12

19 years ago
Inserting Milestone info.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.