In Page Info->Media, unknown protocols (eg rtsp) are changed to http

RESOLVED INVALID

Status

()

Core
DOM: Core & HTML
--
major
RESOLVED INVALID
14 years ago
9 years ago

People

(Reporter: Jeremy M. Dolan, Assigned: db48x)

Tracking

({helpwanted})

Trunk
x86
All
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
Load the page in the URL field. May require a visit first to:
  http://www.petatv.com/tvpopup/Prefs.asp?video=mym2002
to set realplayer as your prefered media type.

Enter Page Info->Media.
Look for the entry of type 'embed'. Notice the location listed is:
   http://a787.v91358.c9135.g.vr.akamaistream.net/ondemand/...etc
Save as, or pasting the URL to Real Player don't work.

Look in view source.
Notice the actual location is the same as above, but with the rtsp protocol.

Beacause of this there's no way to use Page Info to quickly access embeded
content for which there is no plugin available, only a stand alone player.
Is getAbsoluteURL messing up?  Now that most of those DOM props return absolute
URIs, most calls to it can be removed... and the <base> and xml:base stuff can
be replaced with a get of the baseURI property.
Keywords: helpwanted
(Assignee)

Comment 2

14 years ago
It's not page info's fault. Go to that page and type
javascript:alert(document.getElementsByTagName("embed")[0].src); into the
urlbar, it returns the same thing. The problem is therefore in the dom.
Component: Page Info → DOM HTML
OS: Linux → All

Comment 3

14 years ago
I feel that it is not Mozilla's problem. In the source, the 'src' attribute of
the embed tag has the url as "http://...". This is shown in the info.
If you select the windows media player, the generated page embeds with
src="mms://...". The page info displays the information properly.

I feel that the problem is with the asp page generating this page.

Comment 4

12 years ago
I second comment 3: the server sends src="http://a787.v91358..." as the embed 
tag's attribute. Page Info is telling the truth.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Updated

9 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: general
You need to log in before you can comment on or make changes to this bug.