If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

message filter doesn't work when exception rule is added.

RESOLVED INCOMPLETE

Status

Thunderbird
Message Compose Window
RESOLVED INCOMPLETE
14 years ago
10 years ago

People

(Reporter: sean jiang, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.91 KB, application/x-gtar
Details
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: ThunderBird

I created the following message filter:
(Match All of the Following)
1. To or CC, Contains "mail_group1"
2. To or CC, doesn't contain, "sean.jiang"

Actions:
1. Move to folder "mail_group1" folder in local folders.
2. Delete the message.

(I want to filter all message sent to this mailgroup1 (except when the To or CC 
contains my name in it) to be moved to a "mail_group1" folder.

But, this doesn't work, It DOESN'T move any message when it contains mailgroup1 
in the To or CC.

Reproducible: Always

Steps to Reproduce:
I created the following message filter:
(Match All of the Following)
1. To or CC, Contains "mail_group1"
2. To or CC, doesn't contain, "sean.jiang"

Actions:
1. Move to folder "mail_group1" folder

(I want to filter all message sent to this mailgroup1 (except when the To or CC 
contains my name in it) to be moved to a "mail_group1" folder.

But, this doesn't work, It DOESN'T move any message when it contains mailgroup1 
in the To or CC.

Now if you receive a messge that is sent to this mail_group1, it doesn't get 
moved to the specified folder.  It stays in the INBOX folder.
Actual Results:  
Now if you receive a messge that is sent to this mail_group1, it doesn't get 
moved to the specified folder.  It stays in the INBOX folder.

Expected Results:  
Thunderbird should move the message to "mail_group1" folder and remove the 
message from the INBOX.

Comment 1

14 years ago
What happens if you remove the second action (Delete the message) and just move
the message?
Look into mail source by "View/Message Source".
Does "To:" or "CC:" header contain a string of "mail_group1"?
Does not "To:" or "CC:" header contain a string of "sean.jiang"?
(mailing list address may be placed on another mail header)

Comment 3

14 years ago
I had a similar problem:

I created the following message filter:
Match any of following:
To contains foo-1@bar.com
To contains foo-2@bar.com

Works fine on SSL/imap on my SuSE machine. Copy messages to a Mercury/32 v3.32
imap server, create the same filter and it doesn't work. Create a separate
filter for each address and they both work.
(In reply to comment #0)

Reporter, does problem still exist?
If yes, atatch(not paste) your msgFilterRules.dat in your mail directry for the
mail server and mail source(mail headers only is sufficient) which is expected
to be filtered.

(In reply to comment #3)

> I created the following message filter:
> Match any of following:
> To contains foo-1@bar.com
> To contains foo-2@bar.com
Condition is "To contains foo-1@bar.com" AND "To contains foo-2@bar.com"?
Or condition is "To contains foo-1@bar.com" OR "To contains foo-2@bar.com"?

> create the same filter
Exactly same filters?

Same request to reporter.
If problem still occurs, atatch(not paste) your msgFilterRules.dat in your mail
directry for each mail server and mail source(mail headers only is sufficient) 
which is expected to be filtered.

Comment 5

14 years ago
Created attachment 148932 [details]
mail filter settings

I've attached the message filter which doesn't work and headers for two emails.


Since my last posting this server has created an email which reappears every
time I delete it so I'm coming to the opinion that there might be something
dodgy with the server rather than thunderbird.
(In reply to comment #5)

I tested your attachment 148932 [details] with Mozilla 1.7 Branch 2004-05-18 nightly
build(newer than 1.7 RC2).
WORKSFORME if mails are saved in a folder of POP3 account.
Both mails are successufully moved to another folder by your filter.

What message filter log says?
Because your case is IMAP, server related problem is possibly included,
IMAP protocol log is usually required for problem analysis by developers.
See http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap.

I recommend you to search other appropriate bug or to open a new bug.
Why?
Since no responce to my comment #2 from reporter for 4 months, this bug is to be
closed as invalid, I think.
Nick, see you later in other bug.
QA Contact: message-compose
=> INCOMPLETE no response from reporter
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.