SVG_20020806_BRANCH source build failed in nsCSSParser.cpp

RESOLVED FIXED

Status

()

Core
SVG
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: Takanori MATSUURA, Assigned: Alex Fritze)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031028 Firebird/0.7+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031028 Firebird/0.7+

Firebird + SVG_20020806_BRANCH cannot build because the compile failure of
nsCSSParser.cpp.

Build log is the following.
Build status
  succeed: 2003102803 firebird + 20020806_BRANCH
     fail: 2003103000 firebird or later + 20020806_BRANCH

BTW, how the source of this repositely is generated?

nsCSSParser.cpp
../../../../dist/include/content/nsICSSParser.h:87: warning: `virtual nsresult
   nsICSSParser::ParseStyleAttribute(const nsAString&, nsIURI*,
   nsICSSStyleRule**)' was hidden
nsCSSParser.cpp:116: warning:   by `virtual nsresult
   CSSParserImpl::ParseStyleAttribute(const nsAString&, nsIURI*,
   nsIStyleRule**)'
nsCSSParser.cpp: In function `nsresult NS_NewCSSParser(nsICSSParser**)':
nsCSSParser.cpp:373: cannot allocate an object of type `CSSParserImpl'
nsCSSParser.cpp:373:   because the following virtual functions are abstract:
../../../../dist/include/content/nsICSSParser.h:87:     virtual nsresult
   nsICSSParser::ParseStyleAttribute(const nsAString&, nsIURI*,
   nsICSSStyleRule**)
nsCSSParser.cpp: In member function `PRBool CSSParserImpl::ParseURL(PRInt32&,
   nsCSSValue&)':
nsCSSParser.cpp:3621: no matching function for call to `nsCSSValue::SetURLValue
   (nsCOMPtr<nsIURI>&)'
nsCSSValue.h:292: candidates are: void
   nsCSSValue::SetURLValue(nsCSSValue::URL*)


Reproducible: Always

Steps to Reproduce:
1. get the latest SVG_20020806_BRANCH source from CVS
2. build it
Actual Results:  
build successful

Expected Results:  
build failed at nsCSSParser.cpp

Updated

14 years ago
Summary: SVG_20020806_BRANCH soutce cannot build → SVG_20020806_BRANCH source cannot build
(Reporter)

Updated

14 years ago
Summary: SVG_20020806_BRANCH source cannot build → SVG_20020806_BRANCH source build failed in nsCSSParser.cpp

Comment 1

14 years ago
The last time with the error messages:

c++ -o nsCSSParser.o -c -DOSTYPE=\"Linux2.6\" -DOSARCH=\"Linux\"
-I./../../base/src -I./../../../base/src -I./../../content/src
-I./../../../xul/content/src -I./. -I./../../../xul/base/src 
-I./../../../mathml/content/src -I./../../../mathml/base/src
-I../../../../dist/include/xpcom -I../../../../dist/include/string
-I../../../../dist/include/dom -I../../../../dist/include/gfx
-I../../../../dist/include/layout -I../../../../dist/include/widget
-I../../../../dist/include/caps -I../../../../dist/include/locale
-I../../../../dist/include/unicharutil -I../../../../dist/include/js
-I../../../../dist/include/necko -I../../../../dist/include/mimetype
-I../../../../dist/include/webshell -I../../../../dist/include/htmlparser
-I../../../../dist/include/uconv -I../../../../dist/include/xuldoc
-I../../../../dist/include/xpconnect -I../../../../dist/include/view
-I../../../../dist/include/intl -I../../../../dist/include/pref
-I../../../../dist/include/content -I../../../../dist/include
-I/home/mcadoo/mozilla/dist/include/nspr     -I/usr/X11R6/include   -fPIC 
-I/usr/X11R6/include -fno-rtti -fno-exceptions -Wall -Wconversion
-Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy
-Wno-long-long -pedantic -fshort-wchar -pthread -pipe  -DDEBUG -D_DEBUG
-DDEBUG_mcadoo -DTRACING -g -fno-inline  -I/usr/X11R6/include -DMOZILLA_CLIENT
-include ../../../../mozilla-config.h -Wp,-MD,.deps/nsCSSParser.pp nsCSSParser.cpp
../../../../dist/include/content/nsICSSParser.h:87: warning: `virtual nsresult 
   nsICSSParser::ParseStyleAttribute(const nsAString&, nsIURI*, 
   nsICSSStyleRule**)' was hidden
nsCSSParser.cpp:116: warning:   by `virtual nsresult 
   CSSParserImpl::ParseStyleAttribute(const nsAString&, nsIURI*, 
   nsIStyleRule**)'
nsCSSParser.cpp: In function `nsresult NS_NewCSSParser(nsICSSParser**)':
nsCSSParser.cpp:373: cannot allocate an object of type `CSSParserImpl'
nsCSSParser.cpp:373:   because the following virtual functions are abstract:
../../../../dist/include/content/nsICSSParser.h:87:     virtual nsresult 
   nsICSSParser::ParseStyleAttribute(const nsAString&, nsIURI*, 
   nsICSSStyleRule**)
nsCSSParser.cpp: In member function `PRBool CSSParserImpl::ParseURL(PRInt32&, 
   nsCSSValue&)':
nsCSSParser.cpp:3621: no matching function for call to `nsCSSValue::SetURLValue
   (nsCOMPtr<nsIURI>&)'
nsCSSValue.h:292: candidates are: void 
   nsCSSValue::SetURLValue(nsCSSValue::URL*)
gmake[6]: *** [nsCSSParser.o] Error 1
gmake[6]: Leaving directory `/home/mcadoo/mozilla/content/html/style/src'
gmake[5]: *** [libs] Error 2
gmake[5]: Leaving directory `/home/mcadoo/mozilla/content/html/style'
gmake[4]: *** [libs] Error 2
gmake[4]: Leaving directory `/home/mcadoo/mozilla/content/html'
gmake[3]: *** [libs] Error 2
gmake[3]: Leaving directory `/home/mcadoo/mozilla/content'
gmake[2]: *** [libs] Error 2
gmake[2]: Leaving directory `/home/mcadoo/mozilla'
make[1]: *** [alldep] Error 2
make[1]: Leaving directory `/home/mcadoo/mozilla'
make: *** [alldep] Error 2

My .mozconfig file:

# Options for 'configure' (same as command-line options).
ac_add_options --with-pthreads
ac_add_options --enable-calendar
ac_add_options --enable-md
ac_add_options --with-x
ac_add_options --enable-image-decoders=all
ac_add_options --enable-default-toolkit=gtk2
ac_add_options --enable-xft
ac_add_options --enable-crypto
ac_add_options --enable-xinerama
ac_add_options --enable-svg
ac_add_options --enable-svg-renderer-libart
mk_add_options MOZ_INTERNAL_LIBART_LGPL=1
MOZ_INTERNAL_LIBART_LGPL=1

GCC 3.2.2
GLIBC 2.3.1

I have been getting the same result for the past week or so.
(Reporter)

Comment 2

14 years ago
Error message changed.

nsCSSParser.cpp
nsCSSParser.cpp: In member function `PRBool CSSParserImpl::GetToken(PRInt32&,
   int)':
nsCSSParser.cpp:846: no matching function for call to `nsCSSScanner::Next(int&,
   nsCSSToken&)'
nsCSSScanner.h:140: candidates are: PRBool nsCSSScanner::Next(nsresult&,
   nsCSSToken&)
nsCSSParser.cpp: In member function `PRBool
   CSSParserImpl::GetURLToken(PRInt32&, int)':
nsCSSParser.cpp:863: no matching function for call to `nsCSSScanner::NextURL(
   int&, nsCSSToken&)'
nsCSSScanner.h:143: candidates are: PRBool nsCSSScanner::NextURL(nsresult&,
   nsCSSToken&)

Here is my .mozconfig file
export MOZ_PHOENIX="1"
export MOZ_INTERNAL_LIBART_LGPL="1"
mk_add_options MOZ_PHOENIX="1"
mk_add_options MOZ_INTERNAL_LIBART_LGPL="1"
ac_add_options --with-system-jpeg
ac_add_options --with-system-zlib
ac_add_options --with-system-png
ac_add_options --with-system-mng
ac_add_options --with-pthreads
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --disable-xprint
ac_add_options --disable-mailnews
ac_add_options --disable-composer
ac_add_options --disable-freetype2
ac_add_options --disable-installer
ac_add_options --enable-optimize="-O2 -g -pipe -march=i686"
ac_add_options --enable-crypto
ac_add_options --enable-strip-libs
ac_add_options --enable-reorder
ac_add_options --enable-xinerama
ac_add_options --enable-extensions="default"
ac_add_options --enable-xft
ac_add_options --enable-default-toolkit=gtk2
ac_add_options --enable-svg
ac_add_options --enable-svg-renderer-libart
(Reporter)

Comment 3

14 years ago
It seems to be fixed at 2003111605_trunk + SVG_20020806_BRANCH source.

(Assignee)

Comment 4

14 years ago
The branch was broken for a couple of weeks but should be fixed now.
Note that occassionaly trunk checkins will break the branch for short periods of
time (until I do a merge). In that case please don't file a bug but contact me
directly (email alex@croczilla.com, 'afri' on channel #svg on irc.mozilla.org or
post to netscape.public.mozilla newsgroup), asking for a merge. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.