Closed Bug 224795 Opened 18 years ago Closed 15 years ago

The message was sent successfully, but could not be copied to Your Sent folder.

Categories

(Thunderbird :: Message Compose Window, defect)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: lafriks, Assigned: mscott)

Details

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla Thunderbird 0.3 (20031013)

In Mozilla Thunderbird 0.2 everythin was ok, but now when I use 0.3 it all the
time gives message "The message was sent successfully, but could not be copied
to Your Sent folder." for all my IMAP accounts.

Reproducible: Always

Steps to Reproduce:
1. Compose message from IMAP accound
2. Press send

Actual Results:  
It gives a message "The message was sent successfully, but could not be copied
to Your Sent folder."

Expected Results:  
Copy mail to sent folder
Build: 20040218

Reporter, can you reproduce this on a newer build.  
Your build is a little old
Problem is still there with:
Mozilla Thunderbird 0.5 (20040207)
Same error here, but not always. About one out of ten saves fail with the
reported error.

Build Mozilla Thunderbird 0.5 (20040208), precompiled binary 
thunderbird-0.5-i686-pc-linux-gtk2-gnu.tar.bz2 from mozilla.org.
I can confirm the same intermittent (as reported in #3) behaviour in 0.7 / 0.7.1
on my IMAP accounts.  This is a pretty serious issue to me.
Oops, a little more info, for my comment above (#4):

OS: Windows XP w/ SP1
Build: version 0.7.1 (20040626)
Yep, I've seen this as well.  It seems to happen when thunderbird has been open
for a long time (over a day).  I also see the progress bar go to 100% then hang,
then get that error message with the extra info that the imap TRYCREATE
INBOX/Sent command failed, or something like that.  
This is not just a Windows 2000 bug.  I experienced this on Windows XP.
Ok, ignore the part about it appending it to the previous search term... I don't
know why I thought it was doing that.  Sorry.
Uh.  #8 was meant for a totally different bug.  Please ignore.
XP Pro.

This occurs only when I send an attachment. The message is successfully sent but
without the attachment. I can reproduce this one again and again on build 20040707.

Ken, can you attach or e-mail me an SMTP+IMAP protocol log (assuming you're
using IMAP)

Follow these instructions but replace IMAP:5 with SMTP:5,IMAP:5

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap

After a session where the problem occurs, shutdown, save off the log, startup,
and e-mail the log, after editing out any personal info.

thx.
I just saw it on Thunderbird 0.8 on XP Pro, POP setup, sending Unsent messages.

Only one message had an attachment, and not the first one.

I can't reproduce it, but I'll upload the source of the messages, retrieved via
a text editor from the uncompressed Unsent Messages folder.
See my previous comment.

1) These 6 messages were in my Unsent Messages folder from last night

2) Today I clicked File | Send Unsent Messages

3) It appeared to send the messages, but displayed the error that it was unable
to copy them to my Sent folder.  I looked in my Sent folder, and they weren't
there.

4) I opened the file 'Unsent Messages' in a text editor and copied the attached
from the end of the file (and x'd out all personal info).

Unsent messages hasn't been compacted in awhile, apparently; I rarely use it
and it's 23.2 MB.  Before I switched from Moz 1.7 to TB 0.8, in the last few
days, I did click 'Compact all folders' in Moz, but it seems to have skipped
this folder.
Send Unsent Messages just worked fine, and I still haven't compacted Unsent
Messages, so no evidence of a bug there.
I've logged both a failure and a success case using the instructions David gave
to Ken.  I'll submit them both. 

In order to create the failure case, I merely opened thunderbird and let it idle
overnight.  Sure enough, the first email I tried to send this morning (~7hrs
later) failed.  I removed everything but the SMTP and IMAP stuff pertaining to
the actual failure event.  If the stuff in the log that comes before that is
relevent I can post it too.

The success case was created by merely closing thunderbird, reopening and
sending an email.  Subsequently there's a little extra stuff about indexing the
sub-folders of inbox (I believe) during the transaction.
Brent, what build are you running? .8+ builds from after 09/16 and trunk builds
after 09/12 have code to automatically retry imap urls (though I'm not sure it
would be triggered in your case - does your courier imap server limit you to 4
connections per ip address, and if so, have you set that up in the client
advanced imap server settings?)
(In reply to comment #18)
> Brent, what build are you running? .8+ builds from after 09/16 and trunk builds
> after 09/12 have code to automatically retry imap urls (though I'm not sure it
I was running 0.8

> would be triggered in your case - does your courier imap server limit you to 4
> connections per ip address, and if so, have you set that up in the client
> advanced imap server settings?)

I looked into to, and yes, the courier-imap server is limiting to 4 connections
per IP address.  I had not set this in advanced imap settings.  It is now
corrected.  I will report back if this resolved the issue for me.
(In reply to comment #19)

Following up on my last comment... Setting the server connections limit has NOT
resolved this issue.
confirming this bug on Thunderbird 0.9+ with IMAP+SSL
OS,Platform -> all
Flags: blocking-aviary1.0?
OS: Windows 2000 → All
Hardware: PC → All
Flags: blocking-aviary1.0? → blocking-aviary1.0-
A sensible workaround for this might be to make thunderbird copy the file to the
Local Folders Sent folder on failure. That way at least you can retrieve the
sent message and copy it manually to your IMAP server later, instead of losing it...
I have seen the same message while using TB (any version) and courier. I solved
the problem by specifically selecting a INBOX/Sent rather than Sent.

I don't have the root folder set to INBOX because then folders are not remembered.
I have just filed a new bug 277620. I get the same error message about not
getting a copy of sent mail. But my new bug is a much more specific case: see
the bug for details.
Hello --

The problems with "save to sent" (IMAP) and "inability to copy multiple msgs to
sent" seemed to co-incide (Bug #275836).  

Either way -- it's all bad.    Note -- dupe @ bug #263279

Per work-arounds discussed in various bugs (changing "save to" preferences from
"save to sent" to specify server-side folder), don't seem to permanently fix the
problem.

Note -- I can't "save to local sent folder" because have various IMAP access
methods (ie. the REASON I used IMAP for client access in first place --
server-side email).   Though I have confirmed from associate that this does
indeed provide near-term work around for prob.


Hello -- tbird v1.0rtm example of failed "copy to sent".

Steps:
1) start tbird (after declaring envion vars for log)
2) open Drafts folder -- just to insure can see folder other than Inbox.  Note:
 the final portion of Drafts folder view is where attached tbird log picks up.
3) Control-M (compose msg) -- add one "To" address, and one "BCC" address to
myself.   Type babble for msg body.
4) Control-Enter (send msg).
5) Select Inbox -- see BCC copy appear in Inbox
6) Select Sent folder -- see no copy appear in Sent Folder.

Thanks -G
Garrett, if I'm reading that protocol log correctly, there's a problem on your
server.

we finish the append:

10 OK [APPENDUID 1101141386 3765] Completed

and the server says the uid of the new msg will be 3765. Then, when we fetch the
flags of all the messages in your sent folder, here's what it tells us:

1660[2806a28]: 27fd7f0:mail.dirsec.com:S-Sent:CreateNewLineFromSocket: * 2232
FETCH (FLAGS (\Recent \Deleted \Seen) UID 3765)

so it's saying that the newly appended message is already deleted - there's
nothing in the log that indicates that we're deleting the message, so it must be
happening on the server.

You've chopped off the part of the log where I might be able to tell what kind
of server you're running, so I don't know what it might be. My only guess is
that when we tell the server to set the \Seen flag on the newly appended
message, it also sets the deleted flag, but that's a wild guess.

10 append "Sent" (\Seen) {842+}

if you switch your delete model to the imap delete model in advanced imap server
settings, you'll be able to see that the message is getting copied to your sent
folder, but the server is marking it deleted for some reason.  At this point,
all I can think for you to do is contact whoever's responsible for the imap server.
Hello David --
I have full content of Tbird log from today's trunk -- Feb4'05 (note:  why does
the '//help/about' display v0.6+ ??).

Anyways, the log contains lot's of stuff I would consider "private" and not
necessarily appropriate for public post.  

I'm glad to forward to you directly.   Please advise.  Thanks -Garrett
Failure to copy msg. to Sent folder usually occurs when I have another instance
of TB downloading msgs. as a newsgroup reader. Behavior identical to same bug in
Mozilla (non-TB) 1.x. Eventually TB tells me it could not copy the msg. and
offers me a choice.  Either one opens up the compose window again.
I am currently using:
Fedora Core 4
Thunderbird version 1.0.6-1.1.fc4 (20050720)
Mail server is Exim 4
Also using Squirl mail web interface

I too *was* experiencing this problem exactly as described. However, after
tinkering around I solved it! And I think I know how someone can *potentially*
reproduce it.

So the problem just started occuring two weeks ago. I would open thunderbird,
send a mail, and all was good. After a few moves of messages from INBOX to local
folders and another compose mail and send, I got this annoying problem where the
message gets sent, but hangs on copying sent message to sent folder. If I quit
thunderbird and restart (which I did very often) the same would happen - okay
for a few mails and move/copy, then it starts hanging again.

I searched the internet with google for an answer, and tried all the suggestions
I found with no success.

At the same time, as another personal issue, I was being overloaded with mail.
And I was trying to manage it. In my case I had 22 mail filters scanning the
INBOX and copying mails to local folders. And Thunderbird has been working great
for the last year. However, I realized one of my local folders, when clicked on,
did not display the mails but gave the error "This folder is being accessed by
another process" or something like that (I wish I saved that error message).
Well it turns out, one of my subscribed mail lists was piling up mails at a
high-speed rate and my local folder thunderbird filtered them to got corrupted.
I believe that Thunderbird got stuck on this mail filter.

Now I have read other posts where people say that increasing or decreasing the
number of IMAP connections solve the problem. And I believe this is likely true
because in my case Thunderbird got stuck with this one filter copying messages
from the mail server to the local folder.

I believe an IMAP connection was stuck and thunderbird wants to use it for
"copying to sent folder".
This caused other problems. If I wanted to move mails from imap-INBOX to trash,
Thunderbird would not do it. Any type of copying or moving or saving failed.
However, I could still receive new mails.

When I removed this corrupted local mail folder, and dissabled the mail filter,
Thunderbird works lightening fast again.
Before, retrieving or sending mail took about 2 seconds. But Now (even with my
large incoming mail) Thunderbird will do it in the blink of the eye.

Suggestion for those experiencing this problem?
Disable your filters, restart.
Go through each local folder to make sure you can read the mails in each. If you
get an error like I did, delete the folder. then restart.

This solved problem described in this bug report for me.


-RG
This is a follow up comment from my previous commit.

Summary.
Whether you are using IMAP or POP3, I am *guessing* based on my experience that
the problem might be with how thunderbird manages its connections to the mail
server. And in my case, it seemed to me that thunderbird kept trying to use a
connection to the mail server that was stuck from a previous transaction.

-RG
Like numerous other bugs filed about "won't copy to Sent folder" this bug appears to have reports of many different problems.

Between the 1.7 and 1.8 branches (TB 1.0 and TB 1.5), there were at least three bugfixes for various manifestations of this symptom: bug 123063, bug 163951 and bug 287658; and others prior to the release of TB 1.0.

Lauris: if you are still experiencing the originally reported problem, please say so; if you can generate an IMAP log showing the problem (see comment 11), that would be helpful.

Other reporters: since there's no evidence your problem is the same as the original problem, if you still have a problem with current builds, please open 
a new bug with details, including server type, any error messages, and an IMAP log.
At least for me this bug in 1.5.x not happening anymore.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → WORKSFORME
Thanks.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.