macromedia.com [Dreamweaver MX 2004][TOOL] - Background image as defined in CSS is moved by the padding settings in CSS.

RESOLVED INVALID

Status

Tech Evangelism Graveyard
English US
P1
major
RESOLVED INVALID
14 years ago
3 years ago

People

(Reporter: the7thguest, Unassigned)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925

External CSS file defines the following items for a link (visited,hover, and
active):
font, background image, width, height, and padding.

Mozilla is not showing the link to be the defined size and is also moving the
background image according to the padding setting.

Reproducible: Always

Steps to Reproduce:
1. Go to the supplied URL
2. Look at the top nav bar
3. Compare it with IE

Actual Results:  
Mozilla does not show the desired formatting.

Expected Results:  
What IE did.
(Reporter)

Comment 1

14 years ago
Created attachment 134860 [details]
Working css in IE
(Reporter)

Comment 2

14 years ago
Created attachment 134862 [details]
Not working in Mozilla
(Reporter)

Comment 3

14 years ago
Made page using macromedia dreamweaver mx 2004
> Mozilla is not showing the link to be the defined size

That's because per CSS spec width and height do not apply to non-replaced inline
elements (such as <a>).  See
http://www.w3.org/TR/CSS21/visudet.html#propdef-height and
http://www.w3.org/TR/CSS21/visudet.html#propdef-width

> moving the background image according to the padding setting.

The image should start at the padding edge (see
http://www.w3.org/TR/CSS21/colors.html#propdef-background-position).

so the rendering looks exactly correct, given that CSS.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 5

14 years ago
Reopening for Evangelism...
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 6

14 years ago
We really should contact Macromedia and tell them a thing or two about
their product "Dreamweaver MX 2004" which appearantly generates a lot of
invalid CSS.  It makes me quite upset to see a wellknown company like Macromedia
releasing a brand new product with the kind of errors described in this bug.
Assignee: dbaron → english-us
Severity: normal → major
Status: UNCONFIRMED → NEW
Component: Style System (CSS) → English US
Ever confirmed: true
OS: Windows XP → All
Priority: -- → P1
Product: Browser → Tech Evangelism
QA Contact: ian → english-us
Hardware: PC → All
Summary: Background image as defined in CSS is moved by the padding settings in CSS. → macromedia.com [Dreamweaver MX 2004] - Background image as defined in CSS is moved by the padding settings in CSS.
Version: Trunk → unspecified

Updated

14 years ago
Summary: macromedia.com [Dreamweaver MX 2004] - Background image as defined in CSS is moved by the padding settings in CSS. → macromedia.com [Dreamweaver MX 2004][TOOL] - Background image as defined in CSS is moved by the padding settings in CSS.

Comment 7

4 years ago
URL is obsolete.
[closeme]
Status: NEW → RESOLVED
Last Resolved: 14 years ago4 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.