With "command + (from numeric keypad)" the main body text does not wrap.

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Mike DeVaney, Assigned: Blake Ross)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031026 Firebird/0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031026 Firebird/0.7

I have poor eyesight so I frequently use the "command +" ("+" from the numeric
keypad) to increase font size in my browser.  On page
<http://www.macdailynews.com/> this works equally well on MacOS X 10.2.6 in
Safari 1.0 (v85) and in Firebird 0.7.1). Only when font size gets humongous does
the browser begin to have trouble placing all the page elements "nicely" - the
main body text wraps within its designated object (frame, whatever).  However,
when I go to an article (e.g.
<http://www.macdailynews.com/comments.php?id=P2102_0_1_0>) then the behavior in
Safari is as above, but the behavior in Firebird is different - the main body
text does not wrap.

Reproducible: Always

Steps to Reproduce:
1.Enter "command + (from numeric keypad)" repeatedly.
2.
3.

Actual Results:  
Font size increases but virtual page just grows to the right and quickly the
page/frame cannot be read without scrolling the browser window.

Expected Results:  
The text should wrap within its current object (frame, browser window, etc). 
Most browsers eventually run out of space at very large font sizes - this is OK
- but what is happening on the cited page is unsatisfatory.

Comment 1

15 years ago
-> layout
Component: General → Layout
Product: Firebird → Browser
Version: unspecified → Trunk
The text is in the same table cell as the big "comments" textarea below the
article.  The text wraps to the width of the table cell.  As you zoom, the
textarea gets wider (since its width is set in "cols", and the width of the
chars grows as the font size increases).  This makes the table cell wider, and
makes the text wrap to a bigger and bigger width.

I really have to wonder why this works in Safari... does the textarea size not
change there?
Hmm. I asked hsivonen to test this in Safari, and the textarea also expands
there, and can eventually force a scrollbar. If anything's going on here, it's a
Safari inconsistency. INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.