bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Firebird lost ability to load Java plugin, install does not help, Plugin present




15 years ago
14 years ago


(Reporter: ThomasH, Assigned: Blake Ross)


Firefox Tracking Flags

(Not tracked)




15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Uning WindowsMe, missing in the list of systems provided by Mozilla.

I installed recently Frirebird, or rather unzipped the *.zip file,
imported bookmarks and was thrilled how good the browser is.

Yesterday for no apparent reason Firebird has diplayed the usual 
icon in place of Java applet and claimed that Java is missing on my system.
I made no change of any kind to the system, still I clicked on 
the "get plugin" link and installed Java plugin using the "install"

No help. Both Netscape 4.8 and IE 6 stil use Java as usual. I have 
also as always two Java panels in my Control Panel.

Reproducible: Always

Steps to Reproduce:

I tried to find where are mime types and external application set and
tried to add the plugin manually, but I have not found such place.

I unzipped Mozilla *.zip atop of itself, also to no avail.

Comment 1

15 years ago
Hi Thomas, have you tried using add/remove programs to remove ALL old versions
of Java on your computer, and then installing a fresh copy from www.java.com?
Maybe there's a conflict between versions.

If that doesn't work, I can only suggest either downloading a fresh copy of
Firebird (maybe a bad plug-in ended up in your copy by accident), or you could
try running Firebird with a fresh profile: either trash your old profile
(temporarily at least), or start the profile manager (see:

Comment 2

15 years ago
This does not help! I removed Java, in "windoze" art rebooted,
installed a new java, rebooted, localized Firebird (default)
profile and made a new profile, trashed the old one. 

Still the same: All such plugins like flash or shockwave run,
Java will not, but only with Firebird...

The puzzling issue here is that *it was running* after I 
simply unzipped the *.zip Firebird kit and started the *.exe, 
and now for seemingly no reason it does not. 

Can we debug this, using ENV variables or some log files?

Comment 3

15 years ago
Doh, sorry that didn't help.

Do you still have two Java control panels instead of one?

Also, if you type:


into the location bar and hit return, do you see any Java plugins listed? If so,
which versions?

Comment 4

15 years ago
There is indeed a 2nd (older) Java applet in the COntrol Panel, but its
only an orphan *.cpl file. 

Firebird shows Java Plugin enlisted in about:plugins but the suffixes 
column is empty in all cases.  Other plugins (like Quicktime or Shockwave)
have specific suffixes declared for each mime type.

The Java plugin is enabled via following *.dll's:

    File name: NPJava11.dll
    Java Plug-in 1.4.2_02 for Netscape Navigator (DLL Helper)

    File name: NPJava12.dll
    Java Plug-in 1.4.2_02 for Netscape Navigator (DLL Helper)

    File name: NPJava13.dll
    Java Plug-in 1.4.2_02 for Netscape Navigator (DLL Helper)

    File name: NPJava14.dll
    Java Plug-in 1.4.2_02 for Netscape Navigator (DLL Helper)

    File name: NPJava32.dll
    Java Plug-in 1.4.2_02 for Netscape Navigator (DLL Helper)

    File name: NPJPI142_02.dll
    Java Plug-in 1.4.2_02 for Netscape Navigator (DLL Helper)

each with a combination of applet/beans and versions.
Versions are from 1.1.1 to 1.4.1, a plethora of them.

Comment 5

15 years ago
Odd, the latest version of Java I could find on their website was 1.42_01, so
your version seems to be more recent than the available update. Although I'm
using XP, and maybe they've released a later patch for ME for some reason....

All your plugins sound right (and they don't normally have suffixes associated
with them). My version of Firebird did list one more plugin that you didn't
list, though: NPOJI610.dll, which is the Java Virtual Machine Plugin. If it's
supposed to be there, but missing, I imagine it would cause a lot of problems.
But maybe ME is handled differently to XP in that respect.

Comment 6

15 years ago
Can we debug this somehow? ENV variable, or may I get a 
debug executable?

Comment 7

15 years ago
I'm not sure how to debug that. I'm hoping someone else can help you there, sorry.
Can you confirm that the plugin I mentioned in my last post is present/absent
from your about:plugins list?

Comment 8

15 years ago
Yes, I se it, I must have skipped it from the 1st list of 
*.dll's which I have send. 

    File name: NPOJI610.dll
    Java Plug-in 1.4.2_02 for Netscape Navigator (DLL Helper)

This is the file, in the java\bin directory.

9-16-03  19:01          65,647   ___A_  NPOJI610.dll

Comment 9

15 years ago
One thing I should have noticed sooner, check out the following page:
and look under the question: "How do I install the Java Plugin?"

Apparently you may have to apply a registry patch to get Java to work with
Firebird. It seems that if you've run the standard Mozilla browser in the past
(which most people have at some stage), then the registry item most likely
already exists. But if you don't have Mozilla as well, then the Java plugin
fails to work.

Is this any help? I hope so, because I'm afraid I'm not a software tech and I'm
not gonna be much use for helping you debug further.

Comment 10

15 years ago
Yes, this was it! It works now.

Ah well, I already thought with admiration "Look, the Firebird
does not need this horrible registry hassle at all." A bit 
prematurely, though. Some registry involvement seems unavoidable 
after all.

Comment 11

15 years ago
I think (someone correct me if I'm wrong) it's because Mozilla's installer does
that work for it. So anyone who's used Mozilla before will have the registry
settings already. It looks like they're moving Firebird to an installer now, so
maybe the problem will be fixed. Anyway, glad it worked :)

Comment 12

15 years ago
Can someone with enough privileges please change this to closed.

Comment 13

14 years ago
Closing as WORKSFORME as per comments 10 and 12.
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.