Scroll past end of bookmarks

RESOLVED DUPLICATE of bug 248817

Status

()

Firefox
Bookmarks & History
--
trivial
RESOLVED DUPLICATE of bug 248817
15 years ago
12 years ago

People

(Reporter: Nathan Strom, Assigned: janv)

Tracking

unspecified
Points:
---
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Very minor problem, but it's possible to scroll the bookmarks window down if
you've deleted the last bookmark.

Reproducible: Always

Steps to Reproduce:
1. Add a bookmark to the root bookmarks folder
2. Go to the bookmarks manager
3. select the last bookmark listed (should be the one you added)
4. press 'delete' to remove the bookmark
5. press and hold the down arrow key
Actual Results:  
Window contents scroll up

Expected Results:  
No scrolling, as you're already at the end of the list

Comment 1

15 years ago
Works for me. Win XP 20031105 Firebird/0.7+. If I shrink the bookmarks manager
window so the vertical scroll bar appears, then select and delete the last
bookmark, the scroller remains at the bottom. If I click on the down arrow,
nothing moves.

Nathan, are you using any special themes? Or perhaps it's a bug with your
version that has been fixed since.

Other suggestion is that maybe your bookmarks are slightly corrupted. Can you
reproduce the problem if you run Firebird with a fresh profile? Either
trash your old profile (temporarily at least), or at least just temporarily
remove your bookmarks file, or start the profile manager
(see: http://texturizer.net/firebird/faq.html#profilemanager).

Hope one of these suggestions helps!
(Reporter)

Comment 2

15 years ago
I mean press the down arrow on the keyboard, not the down arrow on the scrollbar.

Using the standard theme... I just tried it on my other computer with a
different bookmarks file, same effect happens.
(Reporter)

Comment 3

15 years ago
Just tried with the 20031107 nightly build, and I still see the bug.

Comment 4

15 years ago
Sorry, Nathan, I misunderstood! Yes, I can see the bug when I press the down
arrow on the keyboard. The bug exists on the Mac version too (20031105
Firebird/0.7+) so probably should have hardware/software set to All.

The bug also exists in the standard Mozilla browser, and is reported as bug
125375. But from what I understand, the bookmarks code has forked between the
two browsers, so this might remain as a separate bug.

Comment 5

15 years ago
*** Bug 210340 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
I see this bug in Firebird 20031130 on Linux.  HW/OS -> All/All.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 7

14 years ago
Notice that this problem only occurs when there is no bookmark selected, as is
the case after deleting the last bookmark in the list.  If the last bookmark is
deleted, and then another bookmark or folder is selected, pressing the down
arrow key will only move the selection to the last bookmark item, and stop there.

Comment 8

14 years ago
Just noticed that this problem does not reproduce on a Firefox trunk build
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a2) Gecko/20040615 Firefox/0.8.0+

The observations I made in comment #7 were noted from Firefox 0.9 branch builds
and Firefox 0.9 final.

Additional confirmation would be desired before taking further action on this bug.

Comment 9

14 years ago
Jan, can you help us with this? It'd be a good one to get for 1.0.
Assignee: p_ch → varga
Flags: blocking-aviary1.0?

Comment 10

14 years ago
would need a patch and some testing to be consider for 1.0. renominate if a
patch appears.
Flags: blocking-aviary1.0? → blocking-aviary1.0-
Not sure how this ought to be resolved, but it's fixed by the fix for bug 248817

*** This bug has been marked as a duplicate of 248817 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.