Use a default pref to control use of automigration

VERIFIED DUPLICATE of bug 18118

Status

Core Graveyard
Profile: BackEnd
P3
normal
VERIFIED DUPLICATE of bug 18118
18 years ago
2 years ago

People

(Reporter: selmer (gone), Assigned: racham)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
There have been some objections raised against automatically migrating profiles
(see bug 18118.)  The net result is that we want to control whether this feature
is enabled by having a default pref.  I propose that the default value of this
default pref should be to use automigration.
(Reporter)

Updated

18 years ago
Target Milestone: M14
(Reporter)

Comment 1

18 years ago
This should get in before beta.

Comment 2

18 years ago
I hope no one is thinking that by putting this in a pref that is not accessible
from the installation UI this will be all better. Unless Netscape/Mozilla wants
to tell us how to modify the pref file that is inside the install before the
installer reads it.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 3

18 years ago
It needs to be a default pref because there isn't any other place to get it from
at install time (no profiles exist.)  The ability to modify it is really just a
matter of documentation, the default pref files are all just text files.

Adding Docs to the CC list.

Comment 4

18 years ago
I know they are, but where are they before the install begins when you do a
clean install? Like I said before though, if it is accessible via the UI (which
it appears it will) then there is no issue. You can't edit a pref that is still
packed up in an installshield .Z file (or similar).
(Reporter)

Comment 5

18 years ago
Sure you can!  Use the CCK product.  Go to the CCK page on Mozilla at
http://www.mozilla.org/projects/cck for more info.  Our sources are in
mozilla/cck on the CVS server, but are not pulled for Seamonkey builds.

Comment 6

18 years ago
I can't believe you people. You are determined to hijack my computer and I do
not get why. The user needs to be able to choose not to migrate. It's that plain
and simple. Nothing that does not allow this in a regular distribution is
acceptable.
(Reporter)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

18 years ago
Seth implemented the pref already as profile.confirm_automigration while fixing
18118.  The default value in the mozilla tree is TRUE.  I believe this meets the
requirements for this bug, so I'm closing this as a dup of bug 18118.

*** This bug has been marked as a duplicate of 18118 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 8

18 years ago
reviewed 18118

Updated

18 years ago
Component: Profile Manager → Profile Manager BackEnd

Comment 9

18 years ago
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.

Comment 10

16 years ago
Mass removing self from CC list.

Comment 11

16 years ago
Now I feel sumb because I have to add back. Sorry for the spam.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.