crash if I open this URL - Latin-9 alphabet? Latin-15 encoding?

RESOLVED WORKSFORME

Status

()

Core
Internationalization
--
critical
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Chris Ruvolo, Assigned: smontagu)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031027
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031027

If I open the URL http://www.cs.tut.fi/~jkorpela/latin9.html Mozilla 1.5
promptly crashes.  This is compiled on RH 6.2.  Mozilla 1.4 appears to be able
to view the page, so this is a regression.  The page nearly validates (extra
</a> tag).

Reproducible: Always

Steps to Reproduce:
1. open given url
2. crash

Actual Results:  
Mozilla crashed.

Expected Results:  
Render the page.

Comment 1

14 years ago
can you post a stacktrace (using GDB) or a Talkback ID for this crash
"mozilla/bin/components/talkback/talkback" ?
Severity: normal → critical
Keywords: crash, stackwanted
(Reporter)

Comment 2

14 years ago
This is not a talkback enabled build.  The binary that got built and installed
(RPM) is stripped, so I'm not sure a gdb backtrace would do you any good.. but I
can't get one anyway.

I can't get mozilla-bin to give me a core file.  I have done "ulimit -c
unlimited" and I am execing mozilla-bin directly and not running the wrapper
script which sets ulimit -c 0.. but its not dumping a core file.

And actually running it under gdb isn't working either.  I get a SIGTRAP or two
before a SIGSEGV .. and this is before I give it the URL of the page that
crashes.  So, I don't know whats going on there..

So, the only thing I have left is that I can give you a strace of the execution.
 Let me know if that would be helpful.

Thanks,
-Chris

Comment 3

14 years ago
do you crash using latest pre-1.6 build or the Firebird XFT build ?
This is probably fixed via bug 213734.
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-1.6/
http://ftp.mozilla.org/pub/mozilla.org/firebird/nightly/latest-0.8/
(Reporter)

Comment 4

14 years ago
This was not an XFT enabled build. Build options are (from the spec file):


%define toolkit_options --disable-freetype2

        ./configure --prefix=%{_prefix} --libdir=%{_libdir} \
        --enable-optimize=$OPTFLAGS \
        --disable-debug \
        --with-default-mozilla-five-home=%{_libdir}/mozilla-%{version} \
        --disable-strip-libs \
        --disable-tests \
        --enable-xinerama \
        --enable-nspr-autoconf \
        --enable-extensions=default,irc \
        --without-mng \
        --enable-crypto \
        --disable-xprint \
        --without-system-nspr \
        --with-system-zlib \
        %{toolkit_options} \
        --mandir=%{_mandir}


I'll see if I can reproduce it with a debug build.
(Reporter)

Comment 5

14 years ago
I'm now running Mozilla 1.6 on the same system and am unable to reproduce this
with the newer version. Resolving as WORKSFORME.

-Chris
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.