the format of a dragged event is wrong(DnD)

VERIFIED INVALID

Status

Calendar
Sunbird Only
VERIFIED INVALID
14 years ago
12 years ago

People

(Reporter: charlie dong, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

The transferred data format of mozilla calendar in week view model is like:
BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.0//EN
METHOD:PUBLISH
BEGIN:VEVENT
UID:a0927314-0dae-11d8-aafc-c8f227f89873
SUMMARY:1
LOCATION:2
STATUS:TENTATIVE
CLASS:PRIVATE
X-MOZILLA-RECUR-DEFAULT-INTERVAL:0
DTSTART:20031105T023500Z
DTEND:20031105T033500Z
DTSTAMP:20031103T033413Z
END:VEVENT
END:VCALENDAR


I think the proper format should be:
BEGIN:VCALENDAR
VERSION
 :2.0
PRODID
 :-//Mozilla.org/NONSGML Mozilla Calendar V1.0//EN
METHOD
 :PUBLISH
BEGIN:VEVENT
UID
 :a0927314-0dae-11d8-aafc-c8f227f89873
SUMMARY
 :1
LOCATION
 :2
STATUS
 :TENTATIVE
CLASS
 :PRIVATE
X-MOZILLA-RECUR-DEFAULT-INTERVAL
 :0
DTSTART
 :20031105T023500Z
DTEND
 :20031105T033500Z
DTSTAMP
 :20031103T033413Z
END:VEVENT
END:VCALENDAR

your format  is :field name<CRLF>:field value<CRLF>. but the 
definition in RFC2445 is: field name:field value<CRLF>.maybe it is another
format defined in RFC2445, but I don't see description in my document about RFC2445

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
the dragged event can not be accepted by other applications, because they  can
not parse the format properly.
(Reporter)

Comment 1

14 years ago
Sorry, I make mistake. the mozilla format is like:
BEGIN:VCALENDAR
VERSION
 :2.0
PRODID
 :-//Mozilla.org/NONSGML Mozilla Calendar V1.0//EN
METHOD
 :PUBLISH
BEGIN:VEVENT
UID
 :a0927314-0dae-11d8-aafc-c8f227f89873
SUMMARY
 :1
LOCATION
 :2
STATUS
 :TENTATIVE
CLASS
 :PRIVATE
X-MOZILLA-RECUR-DEFAULT-INTERVAL
 :0
DTSTART
 :20031105T023500Z
DTEND
 :20031105T033500Z
DTSTAMP
 :20031103T033413Z
END:VEVENT
END:VCALENDAR

and the proper format should be:
BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.0//EN
METHOD:PUBLISH
BEGIN:VEVENT
UID:a0927314-0dae-11d8-aafc-c8f227f89873
SUMMARY:1
LOCATION:2
STATUS:TENTATIVE
CLASS:PRIVATE
X-MOZILLA-RECUR-DEFAULT-INTERVAL:0
DTSTART:20031105T023500Z
DTEND:20031105T033500Z
DTSTAMP:20031103T033413Z
END:VEVENT
END:VCALENDAR

Comment 2

14 years ago
I disagree. From rfc2445 (4.1 Content Lines):
   Any sequence of CRLF followed immediately by a single linear white space 
   character is ignored (i.e., removed) when processing the content type.

This unfolding is supposed to be done before anything else, so this is a valid
content line according to the rfc:
BEG
 IN
 :V
 EVENT
So the bug report should be in the other applications' bugzillas ;)

I don't see why we couldn't use a single line when the info fits on it. But we
clearly shouldn't do a hack just on DnD data, so I'm marking this INVALID.
 
Another bug could be opened on 'Should change calendar format to make importing
to other programs easier' or something. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 3

14 years ago
VERIFIED, helping brant with QA since he's been busy recently.
Status: RESOLVED → VERIFIED
QA Contact: brantgurganus2001 → rlk

Updated

12 years ago
QA Contact: rlkeller → sunbird
You need to log in before you can comment on or make changes to this bug.