cvs-mirror cvs process dying on SVG_20020806_BRANCH checkout

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
--
blocker
RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: david avery, Assigned: Daniel (Leaf) Nunes)

Tracking

Details

(Reporter)

Description

14 years ago
on both win32 cvs Ver 1.11.6 (cygwin) and linux cvs Ver 1.11.1p2(redhat) when
checking out the SVG_20020806_BRANCH ( a partial branch) [updating an existing
brnch tree] cvs-mirror randomly dies when pulling the tree. error returned is :
"cvs [server aborted]: no such tag SVG_20020806_BRANCH"

this is preventing the automated building of the SVG Branch

to duplicate:

pull new SVG_20020806_BRANCH
pull again - random die in SeaMonkeyAll pull or mozilla/other-licenses/libical
what commands are you using to check out and update?  Are you using the
client.mk Makefile?

A quick check shows there are no files on the SVG_20020806_BRANCH within
mozilla/other-licenses/libical, so that error message would be accurate if
you're explicitly pulling that directory with that branch tag.

Looking at the client.mk that's on the SVG_20020806_BRANCH, it looks like
there's not supposed to be any files in mozilla/other-licenses/libical on that
branch.

client.mk is passing an extra flag to cvs to prevent that error (and pull HEAD
if that tag doesn't exist for a particular flag) when pulling using it.  If you
pull manually I would assume you'd need to reproduce that.
s/flag/file/ within the parentheses
(Reporter)

Comment 3

14 years ago
libical pulls OK maybe 80% of the time

it's pulled with the SVG Tag because it uses $(CVSCO) which the SVG branch
client.mk sets to include the "-f -r SVG_20020806_BRANCH" tag

pull is always done with "make -f client.mk pull_all"
I don't claim to be an expert on CVS beyond what I pointed out already, so I'll
defer to Leaf at this point.
(Reporter)

Comment 5

14 years ago
closing - cvs fixed  about 15nov
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.